Eternity macOS builds lack SDL2 frameworks and can't run

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: :angel: :angry: :beer: :bfg: :chaingun: :cheers: :blergh:
View more smilies

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

If you wish to attach one or more files enter the details below.

Expand view Topic review: Eternity macOS builds lack SDL2 frameworks and can't run

Eternity macOS builds lack SDL2 frameworks and can't run

by printz » Mon Mar 26, 2018 12:23

Since migrating to SDL2, the Eternity Engine macOS development builds now require SDL2, SDL2_mixer and SDL2_net framework bundle directories in the app package. I believe they must be in the Resources directory. Right now the builder deployed on drdteam doesn't copy them, causing the binary to fail loading.

Can the builder be modified to copy the framework directories in Resources?

I'm gonna test later if it's sufficient to just put frameworks in Resources, or some other steps need to be done. Are the DRDTeam builds signed?

Top