Page 1 of 1

Reenabling Game Selection Menu

Posted: Sat Nov 11, 2017 16:39
by Space Monkey
So I somehow managed to disable the little pop up menu that normally shows when you launch ecwolf.exe that lets you select which game you want to run (wolf3d, spear of destiny etc.) Any way I can get that back up? Thanks in advance.

Re: Reenabling Game Selection Menu

Posted: Sat Nov 11, 2017 20:05
by Blzut3
You should be able to bring it back by holding down shift while starting the game.

Otherwise you can change the key ShowIWadPicker in your ecwolf.cfg. (%AppData%\ecwolf\ecwolf.cfg on Windows)

Coincidentally just the other day I was thinking about removing that feature. Not that I've seen many reports of people accidentally triggering it, but while it was copied over from ZDoom I'm honestly not sure why someone would want to disable it that way on ZDoom either.

Re: Reenabling Game Selection Menu

Posted: Sun Nov 12, 2017 6:13
by Space Monkey
So holding down shift does nothing, and in my ECWolf.cfg file, I have ShowIWadPicker = 1. Tried changing that to 0 and it changed nothing. Is there a way for me to set what key I want to use to open that menu?

Re: Reenabling Game Selection Menu

Posted: Sun Nov 12, 2017 18:46
by enderandrew
Blzut3 wrote:
Sat Nov 11, 2017 20:05
You should be able to bring it back by holding down shift while starting the game.

Otherwise you can change the key ShowIWadPicker in your ecwolf.cfg. (%AppData%\ecwolf\ecwolf.cfg on Windows)

Coincidentally just the other day I was thinking about removing that feature. Not that I've seen many reports of people accidentally triggering it, but while it was copied over from ZDoom I'm honestly not sure why someone would want to disable it that way on ZDoom either.
I think temporarily disabling it from the command line to load a specific iwad and mod in a batch file is nice, but turning it off permanently can be problematic.

Re: Reenabling Game Selection Menu

Posted: Mon Nov 13, 2017 5:48
by Blzut3
Space Monkey wrote:
Sun Nov 12, 2017 6:13
So holding down shift does nothing, and in my ECWolf.cfg file, I have ShowIWadPicker = 1. Tried changing that to 0 and it changed nothing. Is there a way for me to set what key I want to use to open that menu?
If you had ShowIWadPicker set to 1 then it should be showing up. This probably indicates that ECWolf is only discovering one data set.

You can try using the command line option "--data sod" or whatever the one of the other data sets your trying to load may be. If that fails then you know for sure ECWolf is only discovering the one it's automatically selecting.

Re: Reenabling Game Selection Menu

Posted: Fri Nov 24, 2017 21:47
by NinjaGuido
I ended up just reinstalling ecwolf completely and that fixed it - I'm really not sure how I managed to somehow disable it like that.