Installed ECWolf on a new computer, can't get old saves to work

Advanced Wolfenstein 3D source port based upon Wolf4SDL and ZDoom.
[Home] [Download] [HG builds (Win)] [HG builds (Mac)] [Wiki] [Repo]

Moderator: Blzut3

JoeQ

Installed ECWolf on a new computer, can't get old saves to work

Post by JoeQ » Sun Oct 28, 2018 23:04

Last year I played through all of Wolf3D and SoD (GOG version) on ECWolf ver. 1.3.3 on my old laptop (Win 8.1). A while ago I got a new one (Win 10) and reinstalled everything, copied my old saves to the appropriate folder and started up ECWolf, except that it won't recognize the saves.

I know it's the right folder, since it's where the new saves show up, and my old saves still work fine on my old laptop. Any ideas?

Blzut3
Developer
Developer
Posts: 416
Joined: Sun Jan 24, 2010 22:21

Re: Installed ECWolf on a new computer, can't get old saves to work

Post by Blzut3 » Mon Oct 29, 2018 1:53

There's an issue that I haven't been motivated enough to fix (since honestly this is the first I've heard of anyone running into it besides me) where by the saves store an overly specific location of the files loaded. So if you don't have ECWolf setup the exact same way the saves won't be considered compatible.

There is a work around though. Get the latest development version, then if you start ecwolf from the command prompt with --foreignsave it should allow you to load any save even if ECWolf doesn't think it's applicable to your session. Once you load your save, re-save it and it should be valid again. Let me know if you need step by step instructions on using the command prompt.

JoeQ

Re: Installed ECWolf on a new computer, can't get old saves to work

Post by JoeQ » Mon Oct 29, 2018 11:26

Thanks for the response. I downloaded the development version and used --foreignsave to get it to recognize the saves, but trying to load them just crashes the game and shows an unspecific error message.

Blzut3
Developer
Developer
Posts: 416
Joined: Sun Jan 24, 2010 22:21

Re: Installed ECWolf on a new computer, can't get old saves to work

Post by Blzut3 » Tue Oct 30, 2018 6:58

Reproduced the regression. Will hopefully get that fixed in the next few days.

Blzut3
Developer
Developer
Posts: 416
Joined: Sun Jan 24, 2010 22:21

Re: Installed ECWolf on a new computer, can't get old saves to work

Post by Blzut3 » Thu Nov 01, 2018 0:51

181031-0236 should have the fix.

JoeQ

Re: Installed ECWolf on a new computer, can't get old saves to work

Post by JoeQ » Thu Nov 01, 2018 17:20

Thanks man, that did the trick. I was able to them with --foreignsave and re-saved them so now they work normally! Thanks for the quick response and solution :cheers:

Post Reply

Return to “ECWolf”