Boots to a black Screen on startup.

Moderators: Rachael, dpJudas

Locked
blueinferno776
Corrupt Bootloader
Posts: 26
Joined: Sat Aug 31, 2013 9:16

Boots to a black Screen on startup.

Post by blueinferno776 » Sun Oct 16, 2016 22:54

On build QZDoom-q0.1alpha-220-g49e890f-x64.

Was working great until the later builds, I wiped the ini for a fresh one on startup and still got a black screen on windowed and fullscreen.

I do have a radeon r7 m360 in my laptop for some reason this is not in the dxdiag I have.

I really like were qzdoom is going and cant wait for the first stable release! :D
bluInfdxdiag.txt
My sys info
(109.08 KiB) Downloaded 15 times

User avatar
Rachael
Developer
Developer
Posts: 3617
Joined: Sat May 13, 2006 10:30

Re: Boots to a black Screen on startup.

Post by Rachael » Sun Oct 16, 2016 23:05

First, please try updating your video card driver, as the release you have may be buggy.

If that does not work, try booting with "+vid_used3d true" - it only has to be done once.

What is happening is QZDoom is using the same renderer canvas that GZDoom does for its software renderer, however for some users it appears to not be working, so "vid_used3d" was implemented as a fallback to use ZDoom's renderer canvas. Your card is more than recent enough that this should be a non-issue.
Spoiler: Zen Sarcasm

blueinferno776
Corrupt Bootloader
Posts: 26
Joined: Sat Aug 31, 2013 9:16

Re: Boots to a black Screen on startup.

Post by blueinferno776 » Mon Oct 17, 2016 1:18

Windows 10 has the most asinine auto updater I have ever seen. I Uninstalled my drivers for a clean install and rebooted when it was done. AND windows started to install display drivers in the middle of a reboot.

My laptop is being factory restored thanks to the auto installer that killed my windows os.

I can't do anything right now. I will test qzdoom when I get this fixed to see if I still get a black screen.

blueinferno776
Corrupt Bootloader
Posts: 26
Joined: Sat Aug 31, 2013 9:16

Re: Boots to a black Screen on startup.

Post by blueinferno776 » Tue Oct 18, 2016 8:44

Qzdoom started up with no problems! Runs smooth as it did before.

Gzdoom was working just fine before I fixed my laptop, the opengl render canvas should of worked for Qzdoom. Trying to make sense of it.

dpJudas
Developer
Developer
Posts: 798
Joined: Sat Jul 23, 2016 7:53

Re: Boots to a black Screen on startup.

Post by dpJudas » Tue Oct 18, 2016 12:10

There were some bugs in the GLSL and the defines it used that may have have caused the black screen. OpenGL is a little bit fragile where tiny errors may work just fine on one vendor and totally breaks on another. The GL handling in GZDoom is 1000 times more tested for edge cases like this, which is probably why that runs just fine for you.

blueinferno776
Corrupt Bootloader
Posts: 26
Joined: Sat Aug 31, 2013 9:16

Re: Boots to a black Screen on startup.

Post by blueinferno776 » Wed Oct 19, 2016 0:59

Ok. It was something simple which is good. I thought is was the radeon software drivers or some obscure bug. Safe to say this is resolved. :)

Locked

Return to “Closed Bugs”