[1.4.08 (svn rev 864)] adjusting gamma has no effect

Bugs that have been resolved.

Moderator: Graf Zahl

Locked
User avatar
cantabile
Posts: 6
Joined: Sat Jul 31, 2010 18:02

[1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by cantabile » Sat Jul 31, 2010 18:53

Hi.

As the title says, adjusting the gamma has no effect, be it using F11 or the menu.

Operating system: Arch linux 32 bit
Graphics card: 00:02.0 VGA compatible controller: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller (rev 0c)
Intel graphics driver version: 2.12.0
Xorg version: 1.8.1.902
GZDoom compiled from source using this PKGBUILD: http://aur.archlinux.org/packages/gzdoo ... m/PKGBUILD

<unrelated>
Hmm, that's interesting. The svn checkout command said "Updated to revision 864" but gzdoom says "GZDoom v1.4.8 - SVN revision 763M - SDL version". Is that normal?
</unrelated>

Gez
Developer
Developer
Posts: 1399
Joined: Mon Oct 22, 2007 16:47

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by Gez » Sat Jul 31, 2010 21:07

The repository is currently at r864. However, your PKGBUILD thingie does not seem to take from the trunk, but from a tag:

Code: Select all

_pkg_svntrunk="http://mancubus.net/svn/hosted/gzdoom/tags/${pkgver}/"
If you look at the repository, you'll see that r763 does correspond to the version for the tag.

Try replacing the line above by this:

Code: Select all

_pkg_svntrunk="http://mancubus.net/svn/hosted/gzdoom/trunk/"
and I suppose that it should then let you build the current revision.

User avatar
cantabile
Posts: 6
Joined: Sat Jul 31, 2010 18:02

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by cantabile » Sun Aug 01, 2010 13:14

Gez wrote:The repository is currently at r864. However, your PKGBUILD thingie does not seem to take from the trunk, but from a tag:

Code: Select all

_pkg_svntrunk="http://mancubus.net/svn/hosted/gzdoom/tags/${pkgver}/"
If you look at the repository, you'll see that r763 does correspond to the version for the tag.

Try replacing the line above by this:

Code: Select all

_pkg_svntrunk="http://mancubus.net/svn/hosted/gzdoom/trunk/"
and I suppose that it should then let you build the current revision.
Thanks for clearing that up. I did as you suggested and now I have revision 864. However, the gamma correction problem persists.

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4625
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by Enjay » Sun Aug 01, 2010 18:43

To be clear, how are you trying to change the gamma? I am hitting F11 and it correctly bumps the gamma for me.

User avatar
cantabile
Posts: 6
Joined: Sat Jul 31, 2010 18:02

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by cantabile » Sun Aug 01, 2010 19:37

Enjay wrote:To be clear, how are you trying to change the gamma? I am hitting F11 and it correctly bumps the gamma for me.
I tried hitting F11 - I see the messages at the top of the screen "gamma correction level ...." but the image does not change at all.

I also tried the slider in the menu, with similar results.

Gez
Developer
Developer
Posts: 1399
Joined: Mon Oct 22, 2007 16:47

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by Gez » Sun Aug 01, 2010 20:03

The slider and the key both do the same thing -- they change the same variable. If one fails, the other should fail too.

I wonder if this could be somewhat similar to this old thing, in that a system driver interferes and prevents the application from changing the gamma.

User avatar
GuntherDW
Anime anyone?
Posts: 117
Joined: Sat Nov 12, 2005 1:53
Location: Belgium, Antwerp
Contact:

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by GuntherDW » Sun Aug 08, 2010 21:06

I'm currently "seeing" this bug behaviour too.
I use Linux and have a nvidia card.

It's not the card because I just bought an asus engtx470 and it also appears to have the same issue. (No I did not buy this card just because of this bug :P)
It started occurring with the nvidia drivers hitting 256 I guess.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by Graf Zahl » Wed Sep 08, 2010 10:05

Intel GME965
and
Linux

Sound like a driver bug to me.

User avatar
cantabile
Posts: 6
Joined: Sat Jul 31, 2010 18:02

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by cantabile » Tue Sep 14, 2010 14:27

Can it be a driver bug if xgamma works? I was able to change the gamma just fine with that.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: [1.4.08 (svn rev 864)] adjusting gamma has no effect

Post by Graf Zahl » Tue Sep 14, 2010 14:36

No idea how xgamma works. The gamma functionality depends on SDL being able to communicate with your hardware and both components are outside my control.

Locked

Return to “Closed Bugs”