GZDoom pre-2123 64 and 32bit strange bug with this monster

Bugs that have been resolved.

Moderator: Graf Zahl

Locked
saegiru
Posts: 9
Joined: Thu Jul 03, 2014 18:18

GZDoom pre-2123 64 and 32bit strange bug with this monster

Post by saegiru » Sun Sep 04, 2016 1:01

I use this monster called Incarnate in a lot of my playthroughs, and it seems to work fine in 2-1-1. I am not sure when it got broken in the current dev releases, but it definitely hasn't worked right in the past few releases. Can't quite figure out what changed that broke it, but I am attaching the wad so that you can possibly figure it out. Basically on the dev releases it acts extremely erratic, and won't stop and attack. It just keeps fading in and out and running around like crazy.

In 2-1-1 stable, it works correctly and will just run away if you look at it (like the boos from Super Mario Bros.), and attacks when you have your back turned. Any ideas what might be going on?

Thanks!

https://mega.nz/#!AEMEVRLA!8nZ3Ng97fweh ... YAzqiwoyb8

User avatar
Blue Shadow
Global Moderator
Global Moderator
Posts: 305
Joined: Sun Aug 29, 2010 6:09

Re: GZDoom pre-2123 64 and 32bit strange bug with this monster

Post by Blue Shadow » Sun Sep 04, 2016 5:28

For the A_JumpIfInTargetLOS calls, the FOV parameter is an angle, thus should be in the range of 0 to 359; you're setting it to a value which is out of range (400). This disables the FOV check completely.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: GZDoom pre-2123 64 and 32bit strange bug with this monster

Post by Graf Zahl » Sun Sep 04, 2016 7:32

Clearly an error in the DECORATE definition, the question is, what was this supposed to do? Look all around or just 40° with just a 0 accidentally added?
I altered this check so that values larger than 360 are clamped, but this will still deviate from the fixed point version.
It's a definition error in any case, so if the monster alters its behavior, complain with its creator. With stuff like this there is no perfect fix.

saegiru
Posts: 9
Joined: Thu Jul 03, 2014 18:18

Re: GZDoom pre-2123 64 and 32bit strange bug with this monster

Post by saegiru » Sun Sep 04, 2016 15:15

Ah, thank you! I will contact the creator of the pack that I got it from and let him know, I appreciate the insanely quick and efficient response. :) I'm guessing the issue is probably related to the extra 0, because I can't imagine why they would have put 400 in the first place otherwise... but I'll test different values and see what works best.

Thanks guys!

Locked

Return to “Closed Bugs”