Music too fast in Git Builds

Post a reply

This question is a means of preventing automated form submissions by spambots.
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: :angel: :angry: :beer: :bfg: :chaingun: :cheers: :blergh:
View more smilies

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review

If you wish to attach one or more files enter the details below.

Expand view Topic review: Music too fast in Git Builds

Re: Music too fast in Git Builds

by Blzut3 » Fri Sep 06, 2019 3:17

Both of those sounds work like that in vanilla however the repeat rate on it is tied to the frame rate. Eventually that logic will get reworked so that it does something frame rate independent.

Yes, they're annoying, but that's what mods are for. The walking into the wall sound is easy to disable with SNDINFO. Pretty sure I've written how to do that on this forum somewhere.

Re: Music too fast in Git Builds

by Enjay » Sun Aug 25, 2019 12:47

It does indeed seem to be fixed. Thank you for that. :)

While I'm on about sounds though, I have noticed that in ECWolf, when I press the [USE] button (regardless of whether I am next to a wall or not) I get a noise. What's more, the noise repeats rapidly (it almost sounds like gunfire as a result).

There is also a lighter sound - a little bit like someone knocking gently on wood - when I walk against a wall.

I don't seem to have a copy of the original DOS exe handy, but I checked out another couple of Wolf ports and they were silent when pressing the [USE] button and when walking against a wall. So, I was just wondering if the sounds were intentional? It can get a bit annoying to hear the sound every time I press [USE].

You can hear both the [USE] sound and the lighter wall sound here... ... olfUse.mp3

Re: Music too fast in Git Builds

by Blzut3 » Sun Aug 25, 2019 9:15

Re: Music too fast in Git Builds

by Blzut3 » Fri Aug 23, 2019 2:42

Found a configuration that reproduces the issue. Will update the thread when I get a chance to fix it.

Re: Music too fast in Git Builds

by Enjay » Thu Aug 22, 2019 19:54

Unfortunately, no, I don't. I had some problems with my PC a little while back and had to send it to the factory. It came back with a wiped HD and I haven't got around to setting up a build environment on it (because I don't really need one these days).

FWiW, I just tried x64-190817-0449 again and it did start (with no sound) and i was even able to move. I walked forwards to the first door and pressed [use]. I saw the door start to move and that's when things froze. So, I got a bout a second or so further than I did the last time that I was able to see the play screen.

However, on a second attempt, I just got as far as the "initialization complete" screen and then the game vanished.

Re: Music too fast in Git Builds

by Blzut3 » Thu Aug 22, 2019 8:23

I'll have to play with some settings to see if I can reproduce.

Any chance you still have Visual Studio (any version) installed? If so you should be able to check out the source code. Just feed the project into CMake and it should automatically build all the dependencies for you. See if a debug build points to anything.

Re: Music too fast in Git Builds

by Enjay » Wed Aug 21, 2019 19:37

Sorry, I didn't notice this post going up. It may, or may not, be fixed. I can't get either 0024 or 0449 to run (in either 32 or 64 bit versions). In 0449 I usually get as far as a message on the title screen that says "Initialisation Complete" and then I just get dropped back to the desktop. 0024 tends to just hang and Windows tells me that it has stopped responding.

I did once get 0449 going further. I got the menu and was able to start a game but there was no sound. I didn't even get as far as being able to move though. As soon as the game svreen appeared, the game hung and I got a Windows "has stopped responding" message (i.e. the message that I usually get with 0024 even though this was 0449).

Re: Music too fast in Git Builds

by Blzut3 » Fri Aug 02, 2019 5:27

Re: Music too fast in Git Builds

by Enjay » Mon Jul 22, 2019 11:24

Well, that's apparently where the problem lies. I'm running a 5.1 system. If I change my RealTek preferences so that it is only outputting stereo, music plays normally.

Re: Music too fast in Git Builds

by Blzut3 » Mon Jul 22, 2019 2:22

What is your audio setup? It's working fine for me with standard 2.0 speakers.

Re: Music too fast in Git Builds

by Enjay » Sun Jul 21, 2019 1:30


Re: Music too fast in Git Builds

by Master O » Fri Jul 19, 2019 12:42

Music too fast in Git Builds

by Enjay » Thu Jul 18, 2019 17:22

I don't see this mentioned anywhere else. For me the music is playing too fast in recent git builds (both x86-190622-1539 and x64-190622-1539). ... ooFast.mp3

Official release 1.3.3 is working just fine.

Using RealTek HD Audio on Windows 10. Drivers and Windows up to date.

[edit] Actually, I just realised that the menu sounds in the above MP3 sound too fast as well. Most in game sounds seem to be about right but pickups seem weird as does the pushing against a wall sound. Game speed generally is fine. (longer sound file uploaded)[/edit]