automap functions malfunctioning

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: :angel: :angry: :beer: :bfg: :chaingun: :cheers: :blergh:
View more smilies

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

If you wish to attach one or more files enter the details below.

Expand view Topic review: automap functions malfunctioning

Re: automap functions malfunctioning

by Blzut3 » Wed Jul 08, 2020 7:42

Are you only using the overlay automap or the normal automap? The settings you mention only apply to the non-overlay automap.

As for CTRL, it's likely your video card drivers or some other software (likely HP bloatware?) running and you're triggering some global hot key. There's not really anything that ECWolf can do about that, you would need to find what software is the culprit and disable the hot key (or remove the software if it's not needed).

automap functions malfunctioning

by WayneCa » Wed Jul 08, 2020 0:10

I have just downloaded ECWolf for the first time. It is version 1.3.3 64-bit. I am running it under Windows 10 on my HP Pavilion core i5 notebook. The processor is 2.3/2.4 GHz, I have 6GB RAM and a 1TB internal drive. The game is functioning well, except for the automap, or so I think.

The Draw Floor Textures option under Automap does nothing. I see the level screen through the map.
The Pause Game option does nothing. I can still move around and play the game while the map is displayed.
The Show Level Ratios option does nothing. All I see is the walls and doors of the level forming the shape of the level.

Also, I am seeing another problem that I thought was unique to DOSBox. The CTRL key causes the ECWolf window to lose focus. In DOSBox (only while running Wolfenstein 3D), both the CTRL and SHIFT keys do this. In DOSBox and in ECWolf I have remapped the fire button to the Z key. This works, but my finger tends to hit the Windows key which still causes the window to lose focus. Is there something that can be done (if anyone knows) to stop this behavior so I can use the keys originally intended for the fire button?

I do not have a mouse or a joystick. My laptop has a touchpad, and it is not very useful for playing games.

Top