Vavoom engine advanced renderer test

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: :angel: :angry: :beer: :bfg: :chaingun: :cheers: :blergh:
View more smilies

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

If you wish to attach one or more files enter the details below.

Expand view Topic review: Vavoom engine advanced renderer test

Re: Vavoom engine advanced renderer test

by Firebrand » Wed Jun 02, 2010 23:48

Nash wrote:Perhaps a map with light sources that cast shadows all the time? Maybe some moving light sources to demonstrate real-time shadows?
I would like to make a demo map for this, I might take some time for that later ;).
Nash wrote:Besides shadows, what else is in? With this new lighting system, I take it you are now also lighting model polyons properly (per vertex)?
Yes, also, some things are being drawn using shaders, which will allow some other effects to be implemented in the future :), but we don't know yet what will come with this.
Nash wrote:Now if only someone would fix the sound code so it sounds a lot more like ZDoom's and I might consider permanently switching to Vavoom... ;)
What kind of problems you are having with sound?
Nash wrote:EDIT: Just tried it with models. WHOA SHIT, it ran like ASS! Like, less than 1 FPS. More like, 1 frame every 5 seconds. There was even one time when there were 4 zombiemen in front of me and they all started firing (thus casting shadows all over the place) and Vavoom froze and I had to Ctrl-Alt-Del.
Drawing models is slower because of the calculations for interpolating frames, calculating which parts of the model should be lit and casting of shadows, obviously it's still not perfected performance wise (but it has been improved a lot, believe me...). Maybe something else can be done for improving performance, let's see.

Re: Vavoom engine advanced renderer test

by Nash » Tue Jun 01, 2010 19:07

Pretty darn smooth! So far I've been only been able to trigger the real-time shadows by firing rockets around and watching the resulting explosion cast shadows... but yeah it's working. Don't you have a test map or something that better demonstrates the new features?

Perhaps a map with light sources that cast shadows all the time? Maybe some moving light sources to demonstrate real-time shadows?

Besides shadows, what else is in? With this new lighting system, I take it you are now also lighting model polyons properly (per vertex)?

It runs super smooth on my ATI 4870 X2 at 1600 x 1200.

Now if only someone would fix the sound code so it sounds a lot more like ZDoom's and I might consider permanently switching to Vavoom... ;)

EDIT: Just tried it with models. WHOA SHIT, it ran like ASS! Like, less than 1 FPS. More like, 1 frame every 5 seconds. There was even one time when there were 4 zombiemen in front of me and they all started firing (thus casting shadows all over the place) and Vavoom froze and I had to Ctrl-Alt-Del.

The shadowing looks nice though. The models all seem to cast self shadows as well.


Why is it so slow though? :/ I'm using the latest ATI Catalyst drivers and all of the settings are at factory defaults (so there's nothing like forced AA turned on or anything like that).

Changing to a lower resolution doesn't solve the problem. It still runs SLOW when models and real-time shadows are turned on. Without models, it's pretty smooth though.

Re: Vavoom engine advanced renderer test

by Firebrand » Wed May 26, 2010 1:23

The latest revision has some performance improvements, let us know how it works :).

Re: Vavoom engine advanced renderer test

by Rachael » Thu May 20, 2010 5:20

Is it Direct3D? Just run dxdiag and set the refresh rate override to 85 - it's on the very last tab.

I don't know if there's a way to do that with OpenGL, I think it's card/vendor specific.

Re: Vavoom engine advanced renderer test

by Firebrand » Wed May 19, 2010 23:49

Graf Zahl wrote:Why don't I get 85 Hz then? Is there any way to force a refresh rate? 60 Hz hurts my eyes on a CRT monitor. :(
No, the only thing that comes to mind is play with the VSync option, just to see if you get better results.

Re: Vavoom engine advanced renderer test

by Graf Zahl » Wed May 19, 2010 14:33

Firebrand wrote: Vavoom uses the refresh rate that is set on Windows, I've got mine set to 75 Hz, with the recent changes I can't get more than 70 FPS, even when drawing the automap, performance with the new rendering methods still needs improvements, but it's not easy to get it to the best, I hope that with the time we'll improve them as much as possible :).
Why don't I get 85 Hz then? Is there any way to force a refresh rate? 60 Hz hurts my eyes on a CRT monitor. :(
As for porting dynamic lights, Vavoom's renderer it's very different from the GZDoom renderer, for starters, it's polygonal (based on the Quake renderer) while GZDoom is a slightly modified Doom renderer, I'm sure that it's possible to adapt the renderer to display shadows as the ones in Vavoom, but it might require heavy modifications.
The end result what gets rendered is mostly the same, i.e. polygons for walls and triangle fans for subsectors. Doing the lighting is certainly doable but this requires one thing that does not exist: A motivated programmer with lots of time to spend on such a feature.

Re: Vavoom engine advanced renderer test

by Firebrand » Wed May 19, 2010 14:26

Graf Zahl wrote:To do this right you need to post-process the sprite's texture buffer. Have a look at GZDoom's SmoothEdges function. Doing such a thing works wonders.
I'll have a look to it and try to implement it on Vavoom, thanks for pointing it out ;).
Graf Zahl wrote:One thing that immediately put me off is that it completely ignores my preferred video settings and forces the refresh rate to 60 Hz. Are you explicitly setting the refresh rate? Most other OpenGL software recognizes that I want to use 85 Hz with 1280x1024 but Vavoom only gets to start with 60. That doesn't look nice on my monitor.
Vavoom uses the refresh rate that is set on Windows, I've got mine set to 75 Hz, with the recent changes I can't get more than 70 FPS, even when drawing the automap, performance with the new rendering methods still needs improvements, but it's not easy to get it to the best, I hope that with the time we'll improve them as much as possible :).
Graf Zahl wrote:Something unrelated: I wanted to check out how Vavoom handles Hellcore's MAP09 but I can't start that WAD because I get a fatal error 'Sprite SSWV is missing rotations.'

1) Why do I get this error?
2) Why is it fatal?
I'm not sure, I'll have to check the WAD file and determine what causes it, it shouldn't be a fatal error, I'll discuss it with Janis.
Graf Zahl wrote:After editing the WAD and going to my favorite vantage point on the steeple the big disappointment sets in:
- 14 fps - second slowest of all ports after Doomsday
- HOMs galore. This map works glitch-free with all other ports I tested it in.
As I said, Vavoom's renderer is still slow, there should be a way to improve the renderer, but it's not easy to find it, if anyone has ideas on this, it would be good to hear them, lol.
dark-slayer-201 wrote:That has the old hacky ones. I meant pore the Realtime lights.
dark-slayer-201 wrote:
dark-slayer-201 wrote:Very good. This is the first time I have played Vavoom. I cannot get it to use 16:9 aspect ratio though.
Is there any possibility of porting the dynamic lights into gzdoom?
GZDoom already has dynamic lights...
That has the old hacky ones. I meant pore the Realtime lights.
Vavoom doesn't yet support 16:9 aspect ratio, it might be implemented later.

As for porting dynamic lights, Vavoom's renderer it's very different from the GZDoom renderer, for starters, it's polygonal (based on the Quake renderer) while GZDoom is a slightly modified Doom renderer, I'm sure that it's possible to adapt the renderer to display shadows as the ones in Vavoom, but it might require heavy modifications.

Re: Vavoom engine advanced renderer test

by dark-slayer-201 » Wed May 19, 2010 13:11

dark-slayer-201 wrote:Very good. This is the first time I have played Vavoom. I cannot get it to use 16:9 aspect ratio though.
Is there any possibility of porting the dynamic lights into gzdoom?
GZDoom already has dynamic lights...
That has the old hacky ones. I meant pore the Realtime lights.

Edit: typo

Re: Vavoom engine advanced renderer test

by Gez » Wed May 19, 2010 12:28

Firebrand wrote:- Not Dark enough: You can enable two options that might solve the problem for you, under the advanced options menu there's the darken lights option, activate it and it will make lights darker, you can also activate the simulate faded lights option, which will simulate dooms fading of lights to the distance :).
I had already those two turned on, actually. :wink: It's still a lot brighter than it is in the original software renderer. GZDoom comes closer to showing the correct darkness level (in Doom sector light mode, and with ambient light level set to the minimum). Maybe different sector lighting modes would be a solution? I haven't seen the option anywhere.
dark-slayer-201 wrote:Very good. This is the first time I have played Vavoom. I cannot get it to use 16:9 aspect ratio though.
Is there any possibility of porting the dynamic lights into gzdoom?
GZDoom already has dynamic lights...

Re: Vavoom engine advanced renderer test

by dark-slayer-201 » Wed May 19, 2010 8:34

Very good. This is the first time I have played Vavoom. I cannot get it to use 16:9 aspect ratio though.
Is there any possibility of porting the dynamic lights into gzdoom?

Re: Vavoom engine advanced renderer test

by Graf Zahl » Wed May 19, 2010 7:39

Firebrand wrote: - Blurred sprite edges: Under advanced options disable the blend sprite borders option.
To do this right you need to post-process the sprite's texture buffer. Have a look at GZDoom's SmoothEdges function. Doing such a thing works wonders.

One thing that immediately put me off is that it completely ignores my preferred video settings and forces the refresh rate to 60 Hz. Are you explicitly setting the refresh rate? Most other OpenGL software recognizes that I want to use 85 Hz with 1280x1024 but Vavoom only gets to start with 60. That doesn't look nice on my monitor.

Something unrelated: I wanted to check out how Vavoom handles Hellcore's MAP09 but I can't start that WAD because I get a fatal error 'Sprite SSWV is missing rotations.'

1) Why do I get this error?
2) Why is it fatal?

After editing the WAD and going to my favorite vantage point on the steeple the big disappointment sets in:
- 14 fps - second slowest of all ports after Doomsday
- HOMs galore. This map works glitch-free with all other ports I tested it in.

Re: Vavoom engine advanced renderer test

by Firebrand » Wed May 19, 2010 2:19

I've got some solutions for the problems you mentioned:

- Not Dark enough: You can enable two options that might solve the problem for you, under the advanced options menu there's the darken lights option, activate it and it will make lights darker, you can also activate the simulate faded lights option, which will simulate dooms fading of lights to the distance :).

- Blurred sprite edges: Under advanced options disable the blend sprite borders option.

I haven't really noticed that the crosshair wasn't being drawn, heh! :)

by Gez » Wed May 19, 2010 0:26

A few general comments, not renderer-specific:
- Alt-tabbing away and back kills mouselook. It turns it into mousestrafe!
- Keyboard input is still not international-friendly (e.g. it treats an AZERTY keyboard as QWERTY)
- Can't bind mouse4 and mouse5

Now that's out of the way, I've made a quick playthrough in Doom II's first two levels. Two issues I've noticed can be summed up with this screenshot:
Image
It's far from being dark enough, and the way the sprite outlines are blurred is a bit glitched.

In the same place, the missing lower textures around the squares in which you drop provoke HOM glitches far more visible than they are in GZDoom.

Lastly, the crosshair seemed invisible in this mode.

Re: Vavoom engine advanced renderer test

by Firebrand » Tue May 18, 2010 23:47

Aha! That might explaing the problem you are having, please use the -opengl parameter when running the game and test again :). If you don't specify the renderer to use, it will force the software renderer (which obviously doesn't has any support for advanced renderer).

Re: Vavoom engine advanced renderer test

by Gez » Tue May 18, 2010 23:36

Firebrand wrote:Just to be sure, you are selecting the OpenGL renderer in the launcher?
I do not use the launcher. I start vavoom.exe directly. Why? Because the launcher always fail to launch the game. Instead it pops up an error messagebox telling me "ChangeResolution: Failed to set default resolution \ Stack trace: ChangeResolution <- CheckResolutionChange <- SCR_Update <- Host_Frame".

So I use the console commands you provided. r_level_renderer 2.

Top