Bio's experience upgrading the server! (live)

Stuff you want Bio to see. [Home]

Moderator: BioHazard

User avatar
Needs more free time.
Posts: 408
Joined: Mon Jul 25, 2005 10:02
Location: Middle of California where there is no air.

Bio's experience upgrading the server! (live)

Post by BioHazard » Thu Oct 05, 2006 2:58

Alrighty, since I have read people's Gentoo experiences all over the place, I'll add one to the list. I'm going to be upgrading my SVN server to 2006.1 and set it up as an SVN/Local Apache server. This is a log of what I have done. Be aware that I have to type all this stuff so the times aren't particularly accurate measures of the time it takes to do something.

Day 1
-17:30- Alrighty, I'm about to take the computer apart...
-17:32- YES! This case takes a full size board! Crap! The CPU fan might not fit under the PSU!
-17:36- CRAP! The PSU covers the CPU fan. I can't have that. I guess I have to try the other board.
-17:45- Cool, this one fits pretty well. Too bad I don't know wether or not this board works...
***I got distracted for an hour talking to people and checking ZDF ***
-18:45- Now then, what other stuff do I need to put in here? Hmm. Looks like all I need is already on the board.
-18:55- Now to plug it in a start it up.
-18:58- It would help if I plugged in the power switch...
-19:00- Uh oh, I press the button and it posts and dies. Now the PSU smells like fish. Great... This was a special power supply too!
-19:07- I took the PSU apart, nothing looks fishy. Hmm.
-19:12- I hooked up my air compressor and blew the 78 days of dust out of it.
-19:18- Upon further inspection of the motherboard, I discovered it was one of those faulty cap boards so I chucked it. Looks like it wasn't the PSU after all... Since I had to switch motherboards, I had to switch cases.
-19:20- I went into the garage to look for another case.
-19:45- I emerged from the garage with a black mid-tower. I got from Comp-Useless a few years ago.
-20:10- When I finished putting in the new motherboard, I hooked it up and powered it on.
-20:12- Hmm, it looks like 95 watts isin't enough to power this computer anymore... Looks like I need another PSU anyway...
-20:15- I went into the garage to look for another PSU.
-20:25- I came back with a 400-watt generic PSU that was in my last-last-last-other computer. This one worked well, ran cool and didn't make a lot of noise, but one of the molex connectors was bad. Nothing a little soldering couldn't fix!
-20:35- 10-minutes and 4 burns later I had the connector soldered back together. I'll play it safe and not use that one though. I taped it up just to make sure.
-20:50- Alright, everything is in the computer and ready for another test, but first, food time. Make sure you eat something messy right over the computer to give it that delicous aroma when it runs. Yeah.
-21:30- Server is hooked up and ready to go.
-21:31- It appears the BIOS doesn't like the cable I attached to the drives. I replaced them from my huge box of IDE cables.
-21:33- I turned on the computer and got:

Code: Select all

This is weasel.(none) (Linux i686 2.6.17-gentoo-r4)
weasel login:
WTF? I already built an SVN server on this drive? I don't remember doing that. Trust me, when you install Gentoo on a machine, you don't forget about it. Wierd. Since this was built for a different set of hardware and without security in mind, I'll have to redo it anyway.
-21:45- I went and got the Gentoo install ISO and put it on a CD. I'll do the install tomorrow.

Code: Select all

cat ~/Desktop/gentoo-x86-minimal.iso > /dev/cdrw
Okay so I used cdrecord instead of cat. :P

*** Wow, I've been really busy with everything from writing programs to getting a new job. I've finally sat down a bit to work on this server. ***

-17:00- Alrighty, I'm wiping the dust off this machine.
-17:15- CD in, booting up.
-17:25- Alrighty, I ran this stuff to get it ready for install:

Code: Select all

# passwd
# ifconfig eth0
# /etc/inti.d/sshd start
-17:30- Now I'm ready to start. I opened the handbook in firefox:

Code: Select all
Since I already know all the stuff in the first 3 sections, I skipped ahead to section 4: preparing the disks. (it's about 1/5th of the way down)
-17:45- I've decided on a partitioning scheme.
While the default Gentoo set-up mentioned in the handbook is okay, I'm going to do this one a bit different.
  1. hda1: 2.5GB OS
  2. hda2: 512MB swap
  3. hda3: *GB data
This way, when I have to update the OS, I can do it with minimal damage to the server data.

*** Iyaa! I got real distracted with other stuff and ended up needing to shut down the server. I'll get back to it tomorrow afternoon. I didn't even work on it for a full hour! ***

DAY 2! (continued)
*** Come on, there is no way 45 minutes counts as a whole day. ***
-17:25- Alrighty, time to open up fdisk:
Mistake #1!: I typed "fdisk /dev/hda1" and created a partition table on a partition, I should have typed:

Code: Select all

fdisk /dev/hda
First of all, have a look at the current partition table with p. The instructions say to delete all the partitions you don't need with d. Do that if you need to. Why you would want to dual-boot a server is beyond me.
-17:35- Okay, now it's time to create partitions. I'll use n and make the partitions according to my table.:

Code: Select all

Command (m for help): n
Command action: p
Partition number (1-4): 1
First cylinder (1-2434, default 1): 1
Last cylinder or +size or +sizeM or +sizeK (1-2434, default 2434): +2560M

Command (m for help): n
Command action: p
Partition number (1-4): 2
First cylinder (313-2434, default 313): 313
Last cylinder or +size or +sizeM or +sizeK (313-2434, default 2434): +512M

Command (m for help): n
Command action: p
Partition number (1-4): 3
First cylinder (376-2434, default 376): 376
Last cylinder or +size or +sizeM or +sizeK (376-2434, default 2434): 2434

Command (m for help): p
Disk /dev/hda: 20.0 GB, 20020396032 bytes
   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1         312     2506108+  83  Linux
/dev/hda2             313         375      506047+  83  Linux
/dev/hda3             376        2434    16538917+  83  Linux
-18:00- Alright, now to set filesystem types and boot flags. First, to set the boot flag, type a and type the number of the boot partition, in this case, 1. To set the filesystem type, press t and select a partition. Then select a filesystem (type l for a list). We are only interested in 83 and 82 ("Linux" and "Linux Swap" respectively). set the swap partition (in this case, 2) to 82.
-18:15- Now, we write the partition tables. This will blow up your drive, but you knew that already. NOTE: If this hoses anything important, creates a hole in the universe or makes you any other way unhappy, don't say I didn't warn you. Anyway, press w and hope you are SSHd into the right computer.
-18:25- Now we're done with fdisk. Time to format. The documentation says we should use ext2 for the boot filesystem, but since the boot and root partitions are the same, I'm going to try ext3.

Code: Select all

# mke2fs -j /dev/hda1
*** Updating Live ***

Return to “Bio's Site-Place”