Operration Serpent / ECWolf on Linux?

Advanced Wolfenstein 3D source port based upon Wolf4SDL and ZDoom.
[Home] [Download] [HG builds (Win)] [HG builds (Mac)] [Wiki] [Repo]

Moderator: Blzut3

Ghost_Of_DOS
Posts: 10
Joined: Wed Sep 09, 2020 21:47

Operration Serpent / ECWolf on Linux?

Post by Ghost_Of_DOS » Fri Sep 11, 2020 4:47

I'm wondering what I would have to do .. to get "Operation Serpent" running in Linux via ECWolf?

Thanks to the Linux port - I have ecwolf running fine with wolf /spear game files. Pretty sure the mod/tc requires the game files as well.

"Operation Serpent is a total conversion for Wolfenstein 3D using the ECWolf source port. Set in a fictional Central American country in the 1980s, Operation Serpent resembles no Wolfenstein mod ever made before or since. Operation Serpent is a tour de force of ECWolf's capabilities, with seven enormous ...." Operation Serpent


Operation Serpent for Wolfenstein 3D - Level 1: Outer Base - Played by WhamNinjaMolehill on Youtube.


Can I have more then one compilation / installation of ecwolf? I downloaded the archive of OS and it's just a single .pk3 file. I tried renaming to ecwolf's pak file to ecwolf.sav and naming the operation serpent file to ecwolf.pk3, but no go.

I didn't figure it would be that easy. Any ideas?

Thanks!

Gho.....

Blzut3
Developer
Developer
Posts: 467
Joined: Sun Jan 24, 2010 22:21

Re: Operration Serpent / ECWolf on Linux?

Post by Blzut3 » Fri Sep 11, 2020 8:23

Code: Select all

./ecwolf serpent1.pk3
Then select wolfenstein 3d when it prompts for base game.

However note that it has some conflicts with ECWolf 1.4 (aka 1.3.99999). If you didn't already you will need to build ECWolf 1.3.3.

You can have as many ECWolf installs of different versions as you want. The only important thing to know is that each version has a different ecwolf.pk3 so you'll need a unique directory for each install so you can have the binary and ecwolf.pk3 in each.

Ghost_Of_DOS
Posts: 10
Joined: Wed Sep 09, 2020 21:47

Re: Operration Serpent / ECWolf on Linux?

Post by Ghost_Of_DOS » Sat Sep 12, 2020 20:52

OK and right now I'm at 1.3.3. I've made a small vertical panel that hides on the left side of my desktop and if I can figure how to create a launcher from the ecwolf file, I'll make one for each game / mod and stack them on the panel.

I tried running serpent1 and there was flick on the screen like something tried to run, but quit. I put the wolf game files in the build directory .. /home/user/ecwolf_build/ecwolf/build/ There was no prompt for base game files.

./ecwolf serpent1.pk3

ReadConfig: Reading the Configuration.
IWad: Selecting base game data.
W_Init: Init WADfiles.
adding ecwolf.pk3, 99 lumps
adding ./audiot.wl6, 288 lumps
adding ./gamemaps.wl6, 120 lumps
adding ./vgagraph.wl6, 149 lumps
adding ./vswap.wl6, 588 lumps
adding serpent1.pk3, 2635 lumps
InitGame: Setting up the game...
SDL_Init: Using SDL 2.0.9
VL_ReadPalette: Setting up the Palette...
ClassDef: Loading actor definitions.
serpent1.pk3:actors/glock.txt:1:25:Warning: Deprecated use of editor number for class 'Glock'.
serpent1.pk3:actors/ak47.txt:57:23:Warning: Deprecated use of editor number for class 'RifleClip'.
serpent1.pk3:actors/enemies.txt:1:20:Warning: Deprecated use of editor number for class 'PistolSoldier'.
serpent1.pk3:actors/shotgun.txt:1:23:Warning: Deprecated use of editor number for class 'Shotgun'.
serpent1.pk3:actors/items.txt:1:33:Error: Actor 'Sandwich' already defined.

Edit: I tried another mod (conflict.pk3) and it runs ok.

./ecwolf conflict.pk3 ..

ReadConfig: Reading the Configuration.
IWad: Selecting base game data.
W_Init: Init WADfiles.
adding ecwolf.pk3, 99 lumps
adding ./audiot.wl6, 288 lumps
adding ./gamemaps.wl6, 120 lumps
adding ./vgagraph.wl6, 149 lumps
adding ./vswap.wl6, 588 lumps
adding conflict.pk3, 554 lumps
InitGame: Setting up the game...
SDL_Init: Using SDL 2.0.9
VL_ReadPalette: Setting up the Palette...
ClassDef: Loading actor definitions.
Invalid frame data for 'ROCKA9'.
Invalid frame data for 'ROCKAG'.
S_Init: Opened audio: 44100Hz (2 channels)
S_Init: Reading SNDINFO defintions.
S_Init: Reading SNDSEQ defintions.
CreateMenus: Preparing the menu system...
DemoLoop: Starting the game loop...

Blzut3
Developer
Developer
Posts: 467
Joined: Sun Jan 24, 2010 22:21

Re: Operration Serpent / ECWolf on Linux?

Post by Blzut3 » Sun Sep 13, 2020 12:28

You are not running 1.3.3 then. That's the error you're getting when you're running 1.3.99999/1.4. It a conflict with the work in progress Blake Stone stuff.

Ghost_Of_DOS
Posts: 10
Joined: Wed Sep 09, 2020 21:47

Re: Operration Serpent / ECWolf on Linux?

Post by Ghost_Of_DOS » Mon Sep 14, 2020 13:31

Yes, 1.3.3 .. I just compiled the source without giving any extra instructions. If I do

Code: Select all

 cd ~/ecwolf_build/ecwolf &&
git tag -l | tail -1
.. I get - 1.3.3.

OK, on the conflicts stuff. I'm on my way out right now, but later on .. I'll try and build a dated/older version of ecwolf for the older mods and/or TCs.

Ghos....

Blzut3
Developer
Developer
Posts: 467
Joined: Sun Jan 24, 2010 22:21

Re: Operration Serpent / ECWolf on Linux?

Post by Blzut3 » Mon Sep 14, 2020 13:33

Code: Select all

git checkout 1.3.3
Edit: To elaborate now that I have the time to write a proper post: The command your ran simply returns what the nearest tag is. This would be 1.3.3 since there hasn't been a release since then. The way to see what version you're running is simply to start Wolf3D, it's shown on the first screen and also shown in the window title bar.

Checkout the 1.3.3 tag with the command above and run make and you should hopefully get an actual 1.3.3 binary.

Ghost_Of_DOS
Posts: 10
Joined: Wed Sep 09, 2020 21:47

Re: Operration Serpent / ECWolf on Linux?

Post by Ghost_Of_DOS » Tue Sep 15, 2020 13:44

Hi Blzut3 .. Thanks!

Alrighty then .. First wolf3d screen: 1.3.9999999.

Code: Select all

git checkout 1.3.3
run make

done

First Wolf3D screen .. 1.3.3

./ecwolf conflict.pk3
ReadConfig: Reading the Configuration.
IWad: Selecting base game data.
W_Init: Init WADfiles.
adding ecwolf.pk3, 72 lumps
adding ./audiot.wl6, 288 lumps
adding ./gamemaps.wl6, 120 lumps
adding ./vgagraph.wl6, 149 lumps
adding ./vswap.wl6, 588 lumps
adding conflict.pk3, 554 lumps
InitGame: Setting up the game...
VL_ReadPalette: Setting up the Palette...
ClassDef: Loading actor definitions.
Invalid frame data for 'ROCKA9'.
Invalid frame data for 'ROCKAG'.
S_Init: Reading SNDINFO defintions.
S_Init: Reading SNDSEQ defintions.
US_Startup: Starting the User Manager.
CreateMenus: Preparing the menu system...
double free or corruption (!prev)
Aborted

============

./ecwolf serpent1.pk3
ReadConfig: Reading the Configuration.
IWad: Selecting base game data.
W_Init: Init WADfiles.
adding ecwolf.pk3, 72 lumps
adding ./audiot.wl6, 288 lumps
adding ./gamemaps.wl6, 120 lumps
adding ./vgagraph.wl6, 149 lumps
adding ./vswap.wl6, 588 lumps
adding serpent1.pk3, 2635 lumps
InitGame: Setting up the game...
VL_ReadPalette: Setting up the Palette...
ClassDef: Loading actor definitions.
S_Init: Reading SNDINFO defintions.
S_Init: Reading SNDSEQ defintions.
US_Startup: Starting the User Manager.
latchcfg.txt:0:0:Warning: Utilizing temporary status bar configuration script.
CreateMenus: Preparing the menu system...
double free or corruption (out)
Aborted

============

./ecwolf
ReadConfig: Reading the Configuration.
IWad: Selecting base game data.
W_Init: Init WADfiles.
adding ecwolf.pk3, 72 lumps
adding ./audiot.wl6, 288 lumps
adding ./gamemaps.wl6, 120 lumps
adding ./vgagraph.wl6, 149 lumps
adding ./vswap.wl6, 588 lumps
InitGame: Setting up the game...
VL_ReadPalette: Setting up the Palette...
ClassDef: Loading actor definitions.
S_Init: Reading SNDINFO defintions.
S_Init: Reading SNDSEQ defintions.
US_Startup: Starting the User Manager.
CreateMenus: Preparing the menu system...
DemoLoop: Starting the game loop...

--

Gho....

Ghost_Of_DOS
Posts: 10
Joined: Wed Sep 09, 2020 21:47

Re: Operration Serpent / ECWolf on Linux? ... Fix?

Post by Ghost_Of_DOS » Thu Sep 17, 2020 3:56

US_Startup: Starting the User Manager.
CreateMenus: Preparing the menu system...
double free or corruption (!prev)
Aborted

Any idea why this happens? .. Anyway to fix?

Blzut3
Developer
Developer
Posts: 467
Joined: Sun Jan 24, 2010 22:21

Re: Operration Serpent / ECWolf on Linux?

Post by Blzut3 » Thu Sep 17, 2020 4:08

Not certain off hand but it's likely that Conflict in the Fatherland requires ECWolf 1.3.99999 aka 1.4. AstroCreep does a lot of development for the latest development version of ECWolf.

ECWolf 1.x doesn't promise backwards compatibility with mods. Patching Operation Serpent to run in the development version isn't particularly hard but you do need to know how to mod for ECWolf to do it. Thus the easiest solution for you is to run 1.3.x for that and development version for everything else that runs in it.

Ghost_Of_DOS
Posts: 10
Joined: Wed Sep 09, 2020 21:47

Re: Operration Serpent / ECWolf on Linux?

Post by Ghost_Of_DOS » Fri Sep 18, 2020 2:28

OK Thanks .. Blzut3.

Yes, can compile the development version as per-the-wiki and use that for latest stuff. I realize 1.x versions may not be compatible with mods, but is there
a way to get back to something like 1.1.0, 1.2.0, 1.3.0 ?? .. there must be one that will run most older mods?

Blzut3
Developer
Developer
Posts: 467
Joined: Sun Jan 24, 2010 22:21

Re: Operration Serpent / ECWolf on Linux?

Post by Blzut3 » Fri Sep 18, 2020 4:56

Given that ECWolf didn't really take off with modders other than Woolie Wool/Executor until 1.3.x series 1.3.3 should be compatible with all old mods. There's a small chance you might run into a mod that requires 1.2.3, but I honestly don't know of any that haven't been updated for 1.3.

So if you have 1.3.3 and 1.3.99999/1.4 you should be good to go with old and new.

Ghost_Of_DOS
Posts: 10
Joined: Wed Sep 09, 2020 21:47

Re: Operration Serpent / ECWolf on Linux? (Update)

Post by Ghost_Of_DOS » Fri Sep 18, 2020 15:25

OK. I've tried a couple more mods and 1.3.3 is aborting with the above mentioned error. I'll try to compile 1.3.99999 again in a different location.

I've searched for the error but can't find a lot about it. I don't know anything about programing and/or scripting, so it's all over my head.

"US_Startup: Starting the User Manager.
CreateMenus: Preparing the menu system...
double free or corruption (!prev)
Aborted"

Edit: I now have both versions compiled. One in ~/ecwolf_build0 and ~/ecwolf_build.
I haven't tried to many mods yet, but - Conflict in the Fatherland (conflict.pk3) works
via 1.3.99999. Still no luck with "Operation Serpent" (serpent1.pk3) with either version.
In 1.3.3 it sets the display to 640x480 and quits. In 1.3.99999 it just quits. Only see a flicker on
the screen.

I'm thinking about (maybe) starting another post to keep track of what mods work with what
versions and what the errors are.

Anyway, I'll leave you alone.

Gho....

Post Reply

Return to “ECWolf”