MIDI support

Advanced Wolfenstein 3D source port based upon Wolf4SDL and ZDoom.
[Home] [Download] [HG builds (Win)] [HG builds (Mac)] [Wiki] [Repo]

Moderator: Blzut3

filipetolhuizen
Posts: 68
Joined: Wed Jun 25, 2014 1:08

MIDI support

Post by filipetolhuizen » Sat Oct 04, 2014 2:23

Hello,
Although MIDI support got a lot better, I experienced a crash today and was probably due to MIDI playing. The report is attached. Hope this helps improve MIDI support.
Attachments
CrashReport.zip
(13.26 KiB) Downloaded 42 times

Blzut3
Developer
Developer
Posts: 451
Joined: Sun Jan 24, 2010 22:21

Re: MIDI support

Post by Blzut3 » Mon Oct 13, 2014 5:30

Can't say MIDI crash reports are going to be all that useful. Unless you can come up with some sequence to reproduce it. They usually result from invalid pointers and stack smashing (hard to debug even with a debug build).

As long as SDL_mixer is being used for MIDI, it's not really supported. From what I read everyone has problem's with SDL_mixer's native MIDI, and from what I see it looks like it's crazy slow to start a song. It's enabled only because it's not any worse than it was before (i.e. not supported at all) and I do intend to have proper MIDI code at some point.

filipetolhuizen
Posts: 68
Joined: Wed Jun 25, 2014 1:08

Re: MIDI support

Post by filipetolhuizen » Mon Oct 13, 2014 16:11

That makes sense. I remember a lot of crashing with the Doomsday engine port upon MIDI restart when SDL_mixer was the default sound lib.

Post Reply

Return to “ECWolf”