Mac dev versions not starting

Advanced Wolfenstein 3D source port based upon Wolf4SDL and ZDoom.
[Home] [Download] [HG builds (Win)] [HG builds (Mac)] [Wiki] [Repo]

Moderator: Blzut3

User avatar
AstroCreep
Your mom is a title.
Posts: 90
Joined: Thu Jan 08, 2015 5:26
Location: Fort Wayne, Indiana, United States
Contact:

Mac dev versions not starting

Post by AstroCreep » Tue Jul 07, 2015 4:17

The mac dev versions don't seem to want to start for me. When I run it from Terminal, it seems to just repeat "mv: ecwolf.bin: No such file or directory
mv: rename ../Frameworks/SDL.framework.new to ../Frameworks/SDL.framework/SDL.framework.new: No such file or directory" over and over again. Only happens for builds after 6/18/15. This just me or is this a known problem?

Blzut3
Developer
Developer
Posts: 452
Joined: Sun Jan 24, 2010 22:21

Re: Mac dev versions not starting

Post by Blzut3 » Tue Jul 07, 2015 4:21

Looks like something that might happen if you install a new version over an old version. Surprised that didn't happen before.

User avatar
AstroCreep
Your mom is a title.
Posts: 90
Joined: Thu Jan 08, 2015 5:26
Location: Fort Wayne, Indiana, United States
Contact:

Re: Mac dev versions not starting

Post by AstroCreep » Tue Jul 07, 2015 4:28

What do I need to do to get it working again? Tried deleting it and starting over and it still doesn't seem to work

Blzut3
Developer
Developer
Posts: 452
Joined: Sun Jan 24, 2010 22:21

Re: Mac dev versions not starting

Post by Blzut3 » Tue Jul 07, 2015 4:31

Weird, that should do it. I'll have to take a look at the build machine and see what happened.

User avatar
AstroCreep
Your mom is a title.
Posts: 90
Joined: Thu Jan 08, 2015 5:26
Location: Fort Wayne, Indiana, United States
Contact:

Re: Mac dev versions not starting

Post by AstroCreep » Tue Jul 07, 2015 4:39

I noticed that some builds are bigger in memory than others. When I turned on Revealer, it showed that there is a hidden file named "ecwolf.bin" in the 6/18 build (one of the bigger ones) that doesn't seem to be in the smaller ones. The smaller ones seem to be the ones that don't work. Might be a clue as to what's goin on?

Blzut3
Developer
Developer
Posts: 452
Joined: Sun Jan 24, 2010 22:21

Re: Mac dev versions not starting

Post by Blzut3 » Tue Jul 07, 2015 11:38

Looks like every other build would fail (and overwrite the good build) since I forgot to re-enable a check.

Made some other changes while I was at it. SDL 1.2 framework updated to latest Mercurial which I think works on all OS X versions. Added 64-bit build for 10.7+ with SDL 2.0. Finally I signed the application so you can run it without completely disabling gatekeeper.

User avatar
AstroCreep
Your mom is a title.
Posts: 90
Joined: Thu Jan 08, 2015 5:26
Location: Fort Wayne, Indiana, United States
Contact:

Re: Mac dev versions not starting

Post by AstroCreep » Wed Jul 08, 2015 2:03

Load up CeeJay's HD pack with the new dev version (or any other mod with weapon bobbing enabled, for that matter). Check out them dancing sprites. Tried to do a video capture but vlc is being stupid.

EDIT - Tech demo is having trouble displaying sprites at all

Post Reply

Return to “ECWolf”