Updating/fixing my mods for v1.3.3+?

Advanced Wolfenstein 3D source port based upon Wolf4SDL and ZDoom.
[Home] [Download] [HG builds (Win)] [HG builds (Mac)] [Wiki] [Repo]

Moderator: Blzut3

Banjo
Posts: 11
Joined: Tue Aug 16, 2016 7:06

Updating/fixing my mods for v1.3.3+?

Post by Banjo » Tue Apr 25, 2017 20:11

I've been away from ECWolf for a good few months, and only had chance to return to it today. I noticed that after updating to the latest stable 1.3.3 build (I was previously using dev build 1.3999 r161001-1930) that my own mod I was working on no longer works. Instead, it just crashes as the game loads up.

Obviously, I need to fix or update something that has been changed/updated in the newer builds of ECWolf... but how do I find out what I need to fix?

EDIT: Fixed the first errors; the cause was that the "Mac version" items no longer seem to be included in ecwolf.pk3 ("macintosh.txt" is entirely gone from the actors folder there) so my mod referencing things like "MacGasTank" was crashing. I fixed it by re-adding "macintosh.txt" to my mod from the older ECWolf pk3 file (and changing a line that is now included in the N3D definitions instead, as far as I can tell). Now my mod loads up!

Second issue now, when I try to start Spear of Destiny... I get a crash with the error: "Expected Integer Constant but got Identifier instead"
The line it points to in my mod is a "things" section, and reads:

Code: Select all

{63,  RedCeilingLight, 0, 0, 0}
Has something changed in the code that I need to thus change my mod to reflect (i.e. replace "RedCeilingLight" with the 'integer' that seems to be expected in its place?) I noticed that the "class" column header there has changed to "newnum". I'm guessing I need to change the strings to the numbers associated with each "thing", found in their actor definition file?

Forgive me, I'm a bit rusty returning to this again!

Blzut3
Developer
Developer
Posts: 381
Joined: Sun Jan 24, 2010 22:21

Re: Updating/fixing my mods for v1.3.3+?

Post by Blzut3 » Wed Apr 26, 2017 1:08

1.3.99999 aka 1.4.0 development is later than 1.3.3 so this should be expected. The map translator issue you're seeing is because you're writing a 1.4 style mod which uses thing names instead of the editor numbers (editor numbers will be deprecated in 1.4). I would probably suggest that you continue to use the development versions.

Banjo
Posts: 11
Joined: Tue Aug 16, 2016 7:06

Re: Updating/fixing my mods for v1.3.3+?

Post by Banjo » Wed Apr 26, 2017 7:55

Thanks, mate! That makes much more sense! I "fixed" the mod to run with 1.3.3 but kept my previous version, and it was a good learning experience to see the difference. Cheers! Back to playing (and modding!).

Post Reply

Return to “ECWolf”

Who is online

Users browsing this forum: No registered users and 1 guest