Two issues with dev builds

Advanced Wolfenstein 3D source port based upon Wolf4SDL and ZDoom.
[Home] [Download] [HG builds (Win)] [HG builds (Mac)] [Wiki] [Repo]

Moderator: Blzut3

enderandrew
Posts: 6
Joined: Tue Nov 07, 2017 8:07

Two issues with dev builds

Post by enderandrew » Wed Mar 27, 2019 4:08

I have been grabbing various HD mods that people have made for Wolfenstein and testing them all out, combining them in a few places.

I found a collection of hires wall textures, but I noticed a handful wouldn't load in game. I checked those files and noticed they were PNG files, just like the rest and the same resolution. But then I noticed something else, they were grayscale PNG files specifically. If I resaved them as indexed color or RGB PNG files, they worked just fine, but as grayscale, ECWolf would not display them.

Also, my personal use HD collection loads just fine on previous dev builds, but doesn't work on the latest dev builds. Sadly there is no log file for me to debug. Doing some troubleshooting and testing, it will load just fine if I remove my decorate and mapinfo files. I'm uploading my PK3 file so you can reproduce and maybe troubleshoot some more.

https://drive.google.com/file/d/1DG04cX ... sp=sharing

enderandrew
Posts: 6
Joined: Tue Nov 07, 2017 8:07

Re: Two issues with dev builds

Post by enderandrew » Wed Mar 27, 2019 8:01

Also, Executor's port of Project Totengraeber for ECWolf won't load.

http://www.areyep.com/diehardwolfers/vi ... php?t=6763

totengraeber.pk3:actors/totstatics.txt:2:16:Warning: Deprecated use of editor number for class 'LightBulb'.
totengraeber.pk3:actors/totstatics.txt:78:13:Error: Actor 'Gurney' already defined.

I extract the PK3 file and grep through it, and I only see Gurney defined once. And now the very next mod I tested is having a similiar issue. Operation Serpent is saying Actor 'Sandwich' is already defined when it is only defined once in the mod.

Blzut3
Developer
Developer
Posts: 440
Joined: Sun Jan 24, 2010 22:21

Re: Two issues with dev builds

Post by Blzut3 » Wed Mar 27, 2019 8:52

The development build has actor definitions for Blake Stone and some of Executor's mods conflict with them. This is part of the 1.x series not having a backward compatibility promise, although I do intend to at some point add namespaces to prevent these kinds of issues.

As for the texturing issue, you should really create a ticket in the bug tracker to make sure this doesn't get lost. I seem to recall that ZDoom once had a bug that sounds similar so it's possible I'm still using the old PNG code.

enderandrew
Posts: 6
Joined: Tue Nov 07, 2017 8:07

Re: Two issues with dev builds

Post by enderandrew » Wed Mar 27, 2019 15:12

The hanging I'm having with my DECORATE and MAPINFO files on Windows in the latest build (that isn't present in builds from late 2018) may be related to this:

https://bitbucket.org/ecwolf/ecwolf/iss ... on-windows

Post Reply

Return to “ECWolf”