Newest Build Breaks Older Game Compatibility

Something not working in GZDoom that's not a bug? Is the display a bit quirky and unexpected? Post here.

Moderator: Graf Zahl

User avatar
Rex Claussen
Developer
Developer
Posts: 2427
Joined: Tue Jul 11, 2006 18:36
Contact:

Newest Build Breaks Older Game Compatibility

Post by Rex Claussen » Wed Feb 08, 2017 14:46

I just obtained and used G2.4pre-359-gf6d6f31. When I tried to run Paranoiac I got the "Execution could not continue" message.

Specifically, it says:

"Script error, "paranoic.pk3: decorate/weaponsammo.txt" line 385:
Unexpected 'misc/w_pkup' in definition of 'PShellBox'"

There are also script errors on line 380 & 385, ("Parent type 'PShell' not found in PShellBox" and "'inventory.pickupsound' requires an actor of type 'inventory'")

I suspect that these are just the start of other errors, but the error checking got interrupted when execution could not continue.

I am able to use G2.2pre-342-gd90f2ba just fine. So something between these 2 versions (Feb 6 & Feb 8) is conflicting with the game.

System specs are:

Processor: Intel Core 2 4400 @ 2 GHz
RAM: 2 GB
OS: Windows 7 Home Premium, 32-bit
DirectX: 11.0
Graphics Card: NVIDIA GeForce GT 240
Dedicated video memory: 1024 MB GDDR5

Return to “Technical Support”