Speed issues in 2.5pre

Something not working in GZDoom that's not a bug? Is the display a bit quirky and unexpected? Post here.

Moderator: Graf Zahl

Locked
Zhadoom
Posts: 57
Joined: Tue Sep 02, 2014 16:06

Speed issues in 2.5pre

Post by Zhadoom » Thu Mar 16, 2017 17:32

Hello Mr Graf! :D

I downloaded the build 2.5pre-47 and realised that its speed is slower than 2.3.2. The speed in 2.3.2 is slower than the one in 2.2.0.

When playing zdcomp 2 after passing the first door, facing the wide yello door, I get about 110fps on a GTX750 and about 70fps on a GTX950M.

I do understand that more/new options and function in GZDoom eat up performance.
However, my question is: What can the user do to speed GZDoom up a bit?

Thanks for your great work and best regards!
zhd
:D

dpJudas
Developer
Developer
Posts: 798
Joined: Sat Jul 23, 2016 7:53

Re: Speed issues in 2.5pre

Post by dpJudas » Fri Mar 17, 2017 4:41

What speed did you get in 2.2.0?

Zhadoom
Posts: 57
Joined: Tue Sep 02, 2014 16:06

Re: Speed issues in 2.5pre

Post by Zhadoom » Fri Mar 17, 2017 20:16

Hello there! :-)

Thanks for your reply! I just made a test with both gfx cards. I used zdcomp2 plus a simple UDFM sector with nothing but a player. This was run from within GZDB. Here are the results.


GTX750
======

zdcomp2 facing the yellow door:

2.2.0 110fps
2.3.2 110fps
2.5pre-47 110fps

128x128 sector (UDMF) with payer1 start only

2.2.0 640fps
2.3.2 590fps
2.5pre-47 500fps


GTX950M
=======

zdcomp2 facing the yellow door:

2.2.0 95fps
2.3.2 80fps
2.5pre-47 70fps

128x128 sector (UDMF) with payer1 start only

2.2.0 290fps
2.3.2 240fps
2.5pre-47 235fps


Any idea?

Thanks for your support!
zhd

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: Speed issues in 2.5pre

Post by Graf Zahl » Fri Mar 17, 2017 21:52

No idea where it's coming from but between 2.3.2 and the current master there has definitely been some slowdown. Got to find out where it came from.

Zhadoom
Posts: 57
Joined: Tue Sep 02, 2014 16:06

Re: Speed issues in 2.5pre

Post by Zhadoom » Tue Mar 21, 2017 16:56

Don't worry too much, Mr Graf, because 2.4.0 is great concerning its speed. :-)

When entering gl_renderbuffers 0 to 2.3.2 and 2.5pre I notice a significant speed increase.

At the moment, I'm perfectly content with 2.4.0. :-)

Happy developing!
Best regards
zhd

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: Speed issues in 2.5pre

Post by Graf Zahl » Tue Mar 21, 2017 20:04

The speed increase is not really surprising because all postprocessing effects plus multisampling are disabled.
Keep in mind that this is a once-per-frame matter, so it will show most noticably on maps which already have good rendering performance. But on maps that really tax the hardware it won't make much of a difference.

The quesion in the end has to be, what is more important - 200 vs. 300 fps or smoother visuals.

Locked

Return to “Technical Support”