[q1.3pre-45-gf523193-x64] HOM in Burghead

Moderators: Rachael, dpJudas

Locked
User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4579
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

[q1.3pre-45-gf523193-x64] HOM in Burghead

Post by Enjay » Tue Jan 03, 2017 21:00

I thought I'd try my Burghead mod in QZDoom. I knew the models and so on wouldn't be there but I just wanted to see what it would look like.

Anyway, in to opening area I got quite a few HOM-like effects:

Image
Image

Neither GZDoom nor ZDoom have problems in this area and DeePsea error checking gives the map a clean bill of health. The HOM effects aren't even in the usual kind of places that I would expect (e.g. somewhere with a missing texture). However, they do seem to be associated with the tree-trunk structures in the map. These are just approximately circular pillars made from 1 sided lines. However, to try and make them reasonably smooth-looking, I made them from a lot of lines (24 or so I think). Could that be confusing QZDoom somehow? What's more, they seem to be allowing the player to see through structures. In the above pics, the bright band in the first one is (I think) the projectiles on the beach (which are on the other side of a single sided line) and the hanging corpse in the second also isn't visible from the forest unless viewed through the HOM.

Link to the mod:
https://www.doomworld.com/idgames/level ... o/njbgpabh

It'll flag up a bunch of errors on startup but I'm working on an improved version to fix those, they aren't relevant to this issue. Load it up and have a wander around in the foresty area at the start (you need to collect the two pickups right in front of you before you are allowed into the forest).

dpJudas
Developer
Developer
Posts: 798
Joined: Sat Jul 23, 2016 7:53

Re: [q1.3pre-45-gf523193-x64] HOM in Burghead

Post by dpJudas » Tue Jan 03, 2017 21:04

Two questions: are you using the poly renderer or the carmack renderer? And also, does turning off truecolor mode help? Oh and one last question - is this with the latest release or a build from master?

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4579
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: [q1.3pre-45-gf523193-x64] HOM in Burghead

Post by Enjay » Tue Jan 03, 2017 21:09

Truecolor makes no difference.

Poly renderer was off. Turning it on seems to fix the HOM.

This was with today's 64 bit build downloaded from the DRD Dev builds.

dpJudas
Developer
Developer
Posts: 798
Joined: Sat Jul 23, 2016 7:53

Re: [q1.3pre-45-gf523193-x64] HOM in Burghead

Post by dpJudas » Tue Jan 03, 2017 21:24

Damn it. Probably means my moving around variables in the software renderer was enough to jinx it. I'll take a closer look.

dpJudas
Developer
Developer
Posts: 798
Joined: Sat Jul 23, 2016 7:53

Re: [q1.3pre-45-gf523193-x64] HOM in Burghead

Post by dpJudas » Wed Jan 04, 2017 4:51

Fixed.

Locked

Return to “Closed Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest