Dynamic lights

Advanced OpenGL source port fork from ZDoom, picking up where ZDoomGL left off.
[Home] [Download] [Git builds (Win)] [Git builds (Mac)] [Wiki] [Repo] [Bugs&Suggestions]

Moderator: Graf Zahl

Locked
Lars
Posts: 9
Joined: Wed Jul 11, 2012 21:59

Dynamic lights

Post by Lars » Thu Jul 26, 2012 1:48

I'm getting a strange effect with dynamic lights enabled. The lights seem to somehow "shine through" solid walls. I'm getting this effect all over the place with all kinds of maps and objects. Is this a known limitation of the GL engine? Or a bug on my system?

Example below is from the beginning of Doom 2 Map 19, The Citadel.
Screenshot_Doom_20120726_023458.jpg
Screenshot_Doom_20120726_023458.jpg (78.46 KiB) Viewed 1436 times

Gez
Developer
Developer
Posts: 1399
Joined: Mon Oct 22, 2007 16:47

Re: Dynamic lights

Post by Gez » Thu Jul 26, 2012 6:49

Known limitation. The engine doesn't know how to cut dynamic light with world geometry.

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4627
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: Dynamic lights

Post by Enjay » Thu Jul 26, 2012 11:36

To be fair, GZDoom does a better job of it than some of the early 3D accelerated games but, yes, known limitation (it's been reported a number of times).

User avatar
Rex Claussen
Developer
Developer
Posts: 2462
Joined: Tue Jul 11, 2006 18:36
Contact:

Re: Dynamic lights

Post by Rex Claussen » Thu Jul 26, 2012 13:04

A couple of work-arounds are as follows:

1. Edit the GLDEFS lump (of lights.pk3 in the GZDooM package, I believe) to reduce the radius of the glow. This will affect relevant light-emiiting items in all wads that you play, unless the wads have their own GLDEFS.
2. When making your own maps, be careful with light-emitting item placement. Adjust their positions so that they don't shine through walls.
3. When using lighting textures (i.e., not light-emitting items such as torches or candles), adjust the radius of the dynamic light to prevent shining through walls. This option, of course, is not available in wads that others have made, unless you choose to edit the dynamic light radii yourself.

Neither of these options truly solves the problem of lights bleeding through solid walls, but they may help to make the lighting seem less unrealisitic.

User avatar
Blue Shadow
Global Moderator
Global Moderator
Posts: 307
Joined: Sun Aug 29, 2010 6:09

Re: Dynamic lights

Post by Blue Shadow » Thu Jul 26, 2012 13:23

Rex Claussen wrote:1. Edit the GLDEFS lump (of lights.pk3 in the GZDooM package, I believe) to reduce the radius of the glow. This will affect relevant light-emiiting items in all wads that you play, unless the wads have their own GLDEFS.
There's a way to globally adjust dynamic lights size and intensity without having to edit every single dynamic light definition, it's in:

Options > Dispay Options > OpenGL Options > Dynamic Lights Options

User avatar
Rex Claussen
Developer
Developer
Posts: 2462
Joined: Tue Jul 11, 2006 18:36
Contact:

Re: Dynamic lights

Post by Rex Claussen » Thu Jul 26, 2012 17:57

Blue Shadow wrote:There's a way to globally adjust dynamic lights size and intensity without having to edit every single dynamic light definition...
Ah, good to know. Thanks.

Locked

Return to “GZDoom”