gzdoom svn repo

Advanced OpenGL source port fork from ZDoom, picking up where ZDoomGL left off.
[Home] [Download] [Git builds (Win)] [Git builds (Mac)] [Wiki] [Repo] [Bugs&Suggestions]

Moderator: Graf Zahl

Locked
foul_owl
Posts: 6
Joined: Sun Jan 27, 2013 23:10

gzdoom svn repo

Post by foul_owl » Sun Jan 27, 2013 23:12

Sorry for the n00b question, but I can't find the url for the svn repo anywhere. I'm trying the following:

svn co http://mancubus.net/svn/gzdoom/trunk/ gzdoom

and getting:

svn: OPTIONS of 'http://mancubus.net/svn/gzdoom/trunk': 200 OK (http://mancubus.net)

Any help would be greatly appreciated! Thanks!

Gez
Developer
Developer
Posts: 1399
Joined: Mon Oct 22, 2007 16:47

Re: gzdoom svn repo

Post by Gez » Sun Jan 27, 2013 23:19

See here for the ZDoom and GZDoom repo URL. But basically, you're using here the URL of the web front-end. The actual repo URL has hosted/ inserted between svn/ and the project name, e.g. svn co http://mancubus.net/svn/hosted/gzdoom/trunk/ gzdoom

foul_owl
Posts: 6
Joined: Sun Jan 27, 2013 23:10

Re: gzdoom svn repo

Post by foul_owl » Sun Jan 27, 2013 23:20

Ah thank you so much. I thought it was something of that nature, but was unsure what the real URL was. Cheers! I'll report back if I have any further issues.

foul_owl
Posts: 6
Joined: Sun Jan 27, 2013 23:10

Re: gzdoom svn repo

Post by foul_owl » Sun Jan 27, 2013 23:54

Sorry, just one more quick question here. What version of FMOD does GZDoom need? Currently have:

/usr/lib/libfmodex64-4.34.20.so

cmake thinks it's ok, then I get:
gzdoom/src/sound/fmodsound.cpp:67:2: error: #error You are trying to compile with an unsupported version of FMOD

Shouldn't cmake be checking the version of fmod here?

User avatar
Tiger
Siberian Tigers Rule All~!!!
Developer
Developer
Posts: 857
Joined: Thu Feb 25, 2010 3:44
Location: United States
Contact:

Re: gzdoom svn repo

Post by Tiger » Mon Jan 28, 2013 0:19

These articles (Linux - Macintosh) might help you out in terms of compiling the binary and what dependencies are required or recommended.
Nicholas 'Tiger' Gautier

foul_owl
Posts: 6
Joined: Sun Jan 27, 2013 23:10

Re: gzdoom svn repo

Post by foul_owl » Mon Jan 28, 2013 1:16

Thanks! I saw that article but it is for "zdoom" whereas I am trying to compile "gzdoom". Is that article still applicable? Thanks!! (Nice avatar btw)

(also my OS is Ubuntu 12.04)

User avatar
Tiger
Siberian Tigers Rule All~!!!
Developer
Developer
Posts: 857
Joined: Thu Feb 25, 2010 3:44
Location: United States
Contact:

Re: gzdoom svn repo

Post by Tiger » Mon Jan 28, 2013 2:50

foul_owl wrote:Thanks! I saw that article but it is for "zdoom" whereas I am trying to compile "gzdoom". Is that article still applicable?
Yes, the article covers both - ZDoom and GZDoom. The only difference between GZDoom and ZDoom is the dependencies, where GZDoom you'll need 'Mesa' for OpenGL libraries\providers and ZDoom - you don't need Mesa. Anyways, you shouldn't have much issues as I was able to compile a GZDoom binary just fine in Kubuntu ;)
Nicholas 'Tiger' Gautier

Locked

Return to “GZDoom”