Plutonia crashes on the Aztec map

Advanced OpenGL source port fork from ZDoom, picking up where ZDoomGL left off.
[Home] [Download] [Git builds (Win)] [Git builds (Mac)] [Wiki] [Repo] [Bugs&Suggestions]

Moderator: Graf Zahl

Locked
Yusaku Godai
RIP AND TEAR!! HUGE GUTS!!
Posts: 3
Joined: Sun May 17, 2015 20:37

Plutonia crashes on the Aztec map

Post by Yusaku Godai » Sun May 17, 2015 21:02

First of all,i'm new to this forum and forgive for some of my grammatical errors as i'm from Finland.

I was playing Brutal Doom with Plutonia.wad and it just crashed on the "Aztec" map for some reason. The other wads work perfectly.

I attached the crash report,so you can take a look.
Attachments
CrashReport.zip
(22.64 KiB) Downloaded 21 times

User avatar
Kappes Buur
Persecution Complex
Posts: 176
Joined: Tue Apr 05, 2011 4:30
Location: British Columbia

Re: Plutonia crashes on the Aztec map

Post by Kappes Buur » Mon May 18, 2015 0:21

Rather than loading everything at once, have you tried to add one file at a time and see when/if the crash happens?

Then, if a crash happens with, let's say the third file, shuffle the loading order to determine if a crash happens again.
It might just be that some of the files are not compatible and thus the crash has nothing to do with GZDoom.

User avatar
Blue Shadow
Global Moderator
Global Moderator
Posts: 307
Joined: Sun Aug 29, 2010 6:09

Re: Plutonia crashes on the Aztec map

Post by Blue Shadow » Mon May 18, 2015 4:29

You are running GZDoom 1.8.2. This is a very old and outdated version. Try something newer, like the latest official release or latest development build.

Yusaku Godai
RIP AND TEAR!! HUGE GUTS!!
Posts: 3
Joined: Sun May 17, 2015 20:37

Re: Plutonia crashes on the Aztec map

Post by Yusaku Godai » Mon May 18, 2015 13:17

Well,i downloaded the newest build and now when i try to start Plutonia it says "Unknow class Shellbox_shell" and with Doom 2 it says "Unknown Doomer2".

Also,i tried adding one file at a time and it didn't work.

BTW,i don't use custom wads.
Attachments
nimetön.png
Here's a screenshot of my ZDL.
nimetön.png (78.38 KiB) Viewed 923 times

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: Plutonia crashes on the Aztec map

Post by Graf Zahl » Mon May 18, 2015 15:42

No custom stuff? And what's with Brutal Doom and all other stuff? The problem lies somewhere in there .

Rachael
Developer
Developer
Posts: 3623
Joined: Sat May 13, 2006 10:30

Re: Plutonia crashes on the Aztec map

Post by Rachael » Mon May 18, 2015 17:34

Pretty much what Graf said. Just because you didn't modify it yourself doesn't mean it's not custom. Everything in your "external wads" section is custom. The only thing that is official with GZDoom is, GZDoom itself, its optional add-ons which are packaged with GZDoom, and the games that it directly supports (Doom/sequels/Hexen/Heretic/Strife/etc) which you must obtain separately.
Spoiler: Zen Sarcasm

User avatar
Kappes Buur
Persecution Complex
Posts: 176
Joined: Tue Apr 05, 2011 4:30
Location: British Columbia

Re: Plutonia crashes on the Aztec map

Post by Kappes Buur » Mon May 18, 2015 19:13

Out of curiosity I downloaded and played the same files you mentioned, without a crash on map03 (Aztec).

Brightmaps.pk3 and lights.pk3 I always install through the ini file
  • Image
Then I installed the other four files in the following order:
  • brutal19.pk3
    taunts and oneliners.pk3
    doommetalvol4.wad
    zdoom-dhtp-20140616.pk3
No crash happened.

Then I shuffled the order of those files, but always with brutal19.pk3 loaded first.
This I did for gzdoom-g2.1.pre-1134, and also for gzdoom-bin-1-8-10_ql which also runs QlEffects on top of it.
Again no crash.

Since I did not experience a crash, this leads me to the question of what hardware you have, in particular which graphics card.

Yusaku Godai
RIP AND TEAR!! HUGE GUTS!!
Posts: 3
Joined: Sun May 17, 2015 20:37

Re: Plutonia crashes on the Aztec map

Post by Yusaku Godai » Mon May 18, 2015 20:33

Here are my specs

Processor :Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
Video Card:NVIDIA GeForce GT 640
Memory:8.2 GB
Operating System:Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit

Also i managed to fix to the "Unknown class" problem,by deleting the save files(on Doom2 and Plutonia),because when i tried to load the save files they gave me that error,so i don't know what was causing them. I'm still kinda new to this stuff,so i hope you don't mind :P

UPDATE:I played Plutonia on the third map and now it didn't crash on the same spot where it originaly happend.

Mechatron
Posts: 2
Joined: Tue May 26, 2015 3:28

Re: Plutonia crashes on the Aztec map

Post by Mechatron » Tue May 26, 2015 3:48

I'm experiencing the same problem, but with Map17 ("Compound").

Lenovo PC
Intel i3-3240, 3.4GHz x4 cores, 8GB RAM
Nvidia GeForce GTS 450
Windows 8.1 Update 1, 64 bit.
GZDoom g2.1.pre-1134ga-59824c (2015-05-07 11:36:31 +0200 build)

Everything was going smoothly when breaking for dinner. The error stared when trying to reload the auto-save.


UPDATE: Tried again a little later and it loaded OK. Maybe another program was interfering with GZD, or it didn't unload completely when I quit earlier. Will advise when I get to Aztec.
Attachments
CrashReport.zip
Crash when loading Map 17 "Compound"
(26.21 KiB) Downloaded 18 times

Rachael
Developer
Developer
Posts: 3623
Joined: Sat May 13, 2006 10:30

Re: Plutonia crashes on the Aztec map

Post by Rachael » Tue May 26, 2015 20:16

Have you tried without the extra addons?
Wad 0: gzdoom.pk3
Wad 1: PLUTONIA.WAD
Wad 2: lights.pk3
Wad 3: brightmaps.pk3
Wad 4: HXRTCHUD-DOOM_V1.2.PK3
Wad 5: GZ-Models.pk3
Wad 6: zdoom-dhtp-20140617.pk3
Wad 7: DoomMetalVol4.zip
Wad 8: DoomMetalVol4.zip:doommetalvol4.wad
Spoiler: Zen Sarcasm

Locked

Return to “GZDoom”