[GZDoom 64bit versions - drops framerate by half no matter what]

Bugs that have been resolved.

Moderator: Graf Zahl

Locked
Martinoz

[GZDoom 64bit versions - drops framerate by half no matter what]

Post by Martinoz » Sun May 29, 2016 17:24

As in the topic, this problem happens only when I use a 64bit version of GZDoom, being it a stable or dev release.
When the rendering interpolation is turned on the 32bit version, the framerate is on the same level like the monitor refreshing rate.
However with the 64bit version and the same option turned on, it's always a twice lower framerate than a monitor's refreshing rate - fe. when my monitor has got a 75Hz refreshing rate, my FPS cap won't be ever higher than 37FPS.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by Graf Zahl » Sun May 29, 2016 18:51

This sounds like a driver bug. I had similar problems with this until approx. 8-10 months ago when this got fixed by a driver update.

What kind of graphics card are you using?

Martinoz

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by Martinoz » Sun May 29, 2016 19:59

Geforce GTX 660, will try with the newest driver.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by Graf Zahl » Sun May 29, 2016 20:45

Which one are you currently using? Like I said, I had the same problem with some older revisions. I am also using NVidia.

Martinoz

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by Martinoz » Sun May 29, 2016 20:55

Ok, updated to the newest drivers, didn't make any changes at all in the 64bit version, framerate still locked at 37FPS.
My drivers are 341.95

User avatar
NeoHippo
Posts: 401
Joined: Tue Sep 13, 2005 0:47
Location: British Columbia Canada

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by NeoHippo » Tue May 31, 2016 9:27

Just for comparison

My system specs:
Image

Currently, I use GZD g2.2pre-1651 x64 with these settings in an autoexec.cfg file:
  • vid_fps 1
    vid_vsync 0
    cl_capfps 0
Playing Enjay's GENE_TECH I get a framerate of 480 fps on average

Image

Using these settings
  • vid_fps 1
    vid_vsync 1
    cl_capfps 1
the framerate drops to ca 37 fps

Image

Considering the CPU, I guess that is acceptable.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by Graf Zahl » Tue May 31, 2016 9:55

Of course it drops to around 35 fps if you disable uncapped frame rate. That has nothing to do with your graphics hardware or CPU.

What this report was about is that the 64 bit version is slower than the 32 bit version (and that is all driver overhead, because I once experienced the same thing.)

elgambitero

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by elgambitero » Sun Aug 07, 2016 17:17

Same here with debian 2.1.1 builds, and also the OSX port (version 0.5.9)

I've always played at solid 60fps, and now I won't get any more than 35 fps.

I found a .deb package of 2.0.1 version in dpkg.com, for Ubuntu Trusty, and it actually ran at 60 fps. (minus glitchy textures, but that was sector corruption in the wad I think)

elgambitero

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by elgambitero » Sun Aug 14, 2016 15:53

I checked in 4chan /doom/ thread with this issue and they told me about this OpenGL 4/ OpenGL 2 version distinction.

So I tried the drdteam deb build for 1.9.1 amd64, and I'm still stuck at 35 fps.

Is this really a 64-bit-only issue?

elgambitero

Re: [GZDoom 64bit versions - drops framerate by half no matter what]

Post by elgambitero » Sun Aug 14, 2016 16:06

elgambitero wrote:Same here with debian 2.1.1 builds, and also the OSX port (version 0.5.9)

I've always played at solid 60fps, and now I won't get any more than 35 fps.

I found a .deb package of 2.0.1 version in dpkg.com, for Ubuntu Trusty, and it actually ran at 60 fps. (minus glitchy textures, but that was sector corruption in the wad I think)
Well, I just found that if I turn on "rendering interpolation" it jumps up to 60fps, dropping to 44 in heavy actor presence, and 30 with heavy actor and effects presence (I test using project brutality)

At this point, I think it's really the limit of my laptop.


So! As some people in /doom/ told me, If the OpenGL implementation installed on the OS is 3.0, and GZDooM 2.1.1 runs on 4.0, you lose GPU acceleration on OpenGL 4.0 features. What the system does, is making those calculations in the CPU, rather than the GPU, so you ed up with framerate drops.

This solves the issue for me, but maybe the 64-bit incongruences may be still present. Not in 1.9.1 though, I'm using 1.9.1 amd64

Locked

Return to “Closed Bugs”