Gzdoom gives me a black screen in full screen mode (sorta)

Bugs that have been resolved.

Moderator: Graf Zahl

angelus04
Posts: 19
Joined: Sat Jul 17, 2010 8:45

Gzdoom gives me a black screen in full screen mode (sorta)

Post by angelus04 » Fri Jun 17, 2016 10:44

What I mean by sorta is if I load Gzdoom in full screen I get a black screen however if I load it in a window and then switch to full screen it works fine and it does this every time I have no idea why. I want to give you more info to help track down the problem but the only thing I can say is I'm using Windows 10 and my computer is a Lenovo computer/monitor all in one desktop. Not sure what video card I'm using but I know other 3d games work fine like Doom 3 doesn't do anything like this so if I can run Doom 3 Gzdoom should have no issues. Anyway please help if you can. Found out what files are needed to diagnose my problem but the forum won't let me upload the msinfo file says its too big
Last edited by angelus04 on Mon Jun 27, 2016 3:58, edited 2 times in total.

angelus04
Posts: 19
Joined: Sat Jul 17, 2010 8:45

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by angelus04 » Mon Jun 27, 2016 3:50

Here is my Dxdiag info
Attachments
DxDiag.txt
(78.3 KiB) Downloaded 27 times

User avatar
Rachael
Developer
Developer
Posts: 3618
Joined: Sat May 13, 2006 10:30

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by Rachael » Mon Jun 27, 2016 6:26

This is a known issue with Intel OpenGL on Windows 10. Try the utility included here.
Spoiler: Zen Sarcasm

_mental_
Developer
Developer
Posts: 256
Joined: Sun Aug 07, 2011 13:36

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by _mental_ » Mon Jun 27, 2016 6:51

Eruanna wrote:This is a known issue with Intel OpenGL on Windows 10. Try the utility included here.
My tool is for different issue: an inability to initialize OpenGL on some Intel drivers. For black screen the solution is to exit and reenter fullscreen mode.

angelus04
Posts: 19
Joined: Sat Jul 17, 2010 8:45

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by angelus04 » Mon Jun 27, 2016 10:01

I tried the utility still having the same problem sadly

User avatar
Rachael
Developer
Developer
Posts: 3618
Joined: Sat May 13, 2006 10:30

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by Rachael » Mon Jun 27, 2016 12:12

Okay, sorry.

Also, please don't bump topics here. If you have more information to provide and your topic has already been read, feel free to make a new post, but please do not make posts that specifically say "bump," as this tends to be annoying. If you're wondering why your post isn't there where you did that, it's because I deleted it.
Spoiler: Zen Sarcasm

angelus04
Posts: 19
Joined: Sat Jul 17, 2010 8:45

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by angelus04 » Mon Jun 27, 2016 16:30

I apologize for that thanks for trying to help me. Windows 10 obviously doesn't like Gzdoom at least on my computer anyway. I'm out of ideas.

angelus04
Posts: 19
Joined: Sat Jul 17, 2010 8:45

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by angelus04 » Mon Jun 27, 2016 16:32

If anyone has any further info like they encountered a similar problem and managed to fix it please post your response here

User avatar
Rachael
Developer
Developer
Posts: 3618
Joined: Sat May 13, 2006 10:30

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by Rachael » Tue Jun 28, 2016 10:01

At this point, it seems like a wait-and-see to see what Graf thinks. I haven't seen him post in the past week or so he may be having real life stuff at the moment (I'm hoping it's fun stuff, but when Doom members go on sudden hiatus it's usually not, so...), but I am sure we'll hear from him soon enough.
Spoiler: Zen Sarcasm

angelus04
Posts: 19
Joined: Sat Jul 17, 2010 8:45

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by angelus04 » Tue Jun 28, 2016 10:22

Thanks hope Graf has a suggestion and hope everything is ok with him

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by Graf Zahl » Wed Jun 29, 2016 11:26

Sorry, I had some internet access problems for the last week.

As for the problem, sorry, no idea. I do not have the affected hardware so I am unable to reproduce and test this. I'm afraid you'll have to wait for someone with debugging skills to experience something similar.

The only advice I can give is to try forcing a lower OpenGL version with the command line parameter -glversion.
Look what the engine reports on startup (save to a file with '+logfile log') and set it to something lower if it's higher than 2. You can also try using '-noshader' to force fixed function features only.

ibm5155
Posts: 152
Joined: Tue Oct 25, 2011 13:05

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by ibm5155 » Wed Jun 29, 2016 13:55

gzdoom-g2.2pre-1752-gaf20f31.7z Works fine with my intel hd 4000 (gl 4.0, Windows 10)...

Hey graf, how could I debug gzdoom? I know how to debug and also how to use visual studio (and also compile gzdoom on it), should I check for some specific area in the code? (like that dynamic light problem that stop working).

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by Graf Zahl » Wed Jun 29, 2016 14:08

If you can get the project set up to compile there's nothing preventing you from running it in the debugger. For that you just have to follow the instructions in the Wiki.
You'll have to get the dependencies set up and run CMake once to create the project files, the rest should be mostly automatic.

For the dynamic lights problem, this sounds like the driver and the game somehow disagree about the uniform buffer for dynamic lights, so the best place to start would be

int FLightBuffer::BindUBO(unsigned int index)

in gl_lightbuffer.cpp and see if it's specific index values that cause a problem.

tron

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by tron » Wed Jun 29, 2016 14:12

I had this issue in Win7 on Dell laptop.
I don't remember how but I've fixed it - in my opinion it is 100% fixable.
I have impression this problem was strictly connected with improper resolution (laptops has slithly different aspec ratio).
As far as I remember I've made change in game menu (in windowed screen) but it is also possible directly in ini. However specific resolution depends on laptop.

ibm5155
Posts: 152
Joined: Tue Oct 25, 2011 13:05

Re: Gzdoom gives me a black screen in full screen mode (sorta)

Post by ibm5155 » Wed Jun 29, 2016 15:53

int FLightBuffer::BindUBO(unsigned int index) was never called.
I don't know if it's related to the latest gzdoom build or the new AMD driver that I installed, but the problem looks like fixed :D

BindUBO wasn't being called because the buffer type was 3529506816 (decimal not hex), I also tried to force it to go inside the BindUBO call but it only resulted in a division by zero (mBlockAlign = 0)

EDIT for the gpu info:
AMD HD8870m.
gzdoom short log:
GL_VENDOR:ATI
GL_RENDERER: AMD RADEON R9 M200X SERIES (AMD renamed that gpu :v)
GL_VERSION: 4.5.13440 CORE PROFILE CONTEXT 0 (CORE PROFILE)
GL_SHADING_LANGUAGE_VERSION: 4.50

Locked

Return to “Closed Bugs”