[Since FP re-write] Some sloped 3D floors don't render

Bugs that have been resolved.

Moderator: Graf Zahl

Locked
AFADoomer
Posts: 43
Joined: Fri Sep 02, 2005 3:23

[Since FP re-write] Some sloped 3D floors don't render

Post by AFADoomer » Sun Jun 19, 2016 1:24

Since the floating point re-write, I've had some issues with sloped 3D-floor rendering... I have multiple sectors with the exact same tags, but seemingly random sectors (the same ones every time) will not display the 3D floors (but only from certain sides). These sectors used to render properly in GZDoom, and still do in GZDoomBuilder (and I haven't edited in months, so nothing in the map changed), so I'm not sure what is different (maybe a map error that was previously hidden?). I've even re-created the 3D floors and re-tagged everything in a different version of the map, to no avail.

You can see an example of this here:
https://github.com/AFADoomer/baseTrekpk ... /MAP06.wad

MAP01
warp -190 0 120

(No textures in the .wad, but you can still see the issue - the wall in front of the player is supposed to be solid, not have angled chunks missing)

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: [Since FP re-write] Some sloped 3D floors don't render

Post by Graf Zahl » Sun Jun 19, 2016 10:49

fixed. This was caused by precision issues when calculating the sector's center. The old algorithm was only working with fixed point precision.

AFADoomer
Posts: 43
Joined: Fri Sep 02, 2005 3:23

Re: [Since FP re-write] Some sloped 3D floors don't render

Post by AFADoomer » Sun Jun 19, 2016 16:26

Confirmed fixed on my end. Thanks!

Locked

Return to “Closed Bugs”