Crash on Archvile fire when gl_render_precise=true

Bugs that have been resolved.

Moderator: Graf Zahl

Locked
JPL
doom hipster
Posts: 3
Joined: Sat Sep 10, 2016 20:19

Crash on Archvile fire when gl_render_precise=true

Post by JPL » Tue Dec 13, 2016 6:22

Running latest from git in 64-bit Arch Linux with Nvidia binary drivers (375.20) on a GTX 660.
Crash happens when you get attacked by an archvile (Plutonia MAP11 a fine testing ground) with gl_render_precise=true in your gzdoom.ini file.
Console output looks like this:

Code: Select all

gzdoom: gzdoom/src/gl/dynlights/a_dynlight.cpp:421: void ADynamicLight::UpdateLocation(): Assertion `radius >= m_currentRadius * 2' failed.
Aborted (core dumped)
Set gl_render_precise=false and the crash doesn't happen, so this is an easy workaround with few (afaict) consequences.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: Crash on Archvile fire when gl_render_precise=true

Post by Graf Zahl » Tue Dec 13, 2016 11:12

It didn't trigger the assert for me even once.
No idea what's happening.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: Crash on Archvile fire when gl_render_precise=true

Post by Graf Zahl » Thu Dec 29, 2016 20:02

This looks like an issue that got already fixed, i.e. the cycler for pulse lights did not always initialize fully.

Locked

Return to “Closed Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest