Win 7 system sounds weird problem

Anything that doesn't fit into other forums.
User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4589
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Win 7 system sounds weird problem

Post by Enjay » Sat May 14, 2016 21:56

OK, so here's a weird one that I can't resolve and I figured that there is a chance that a resident genius here might be able to shed some light on the issue.

A few days ago, some system sounds on my Win7 64 bit machine stopped working some of the time. e.g. if I right click on this page and in most programs or use the start menu, when the context menu pops up, I get a click sound. However, if I right click on the desktop, the menu pops up silently; it used to click too. The asterisk and question dialogues also usually pop up silently where previously they used to make a noise. Other sounds are affected too but media players, games, youtube etc etc all still produce sound. So it just seems to be some system sounds that are affected.

I don't recall doing anything particularly unusual with my machine before I noticed the issue.

What have I done?
Tried turning it off an on again (obviously). Full shutdown and power off.
Checked that the sounds are still there, still work and are correctly pointed to in the control panel sounds applet. All as they should be.
Tried using different sound themes.
Tried reinstalling sound drivers.
Tried using USB headphones to see if the problem was there as well as with my sound card (it was).
Tried creating a new user profile to see if the problem happened there (it did).
Run sfc /scannow
Full virus and malware sweep. All clear.
CCleaner registry check. No problems.
Run Hijackthis. Nothing of concern reported.
Windows update.
Did a google search and checked a few things in my registry that people had reported causing similar symptoms. I did not have any of the problems suggested.

None of the above brought my sounds back or shed any light on what might be going on.

I did a bit more googling and I eventually found an abandoned forum thread where someone described my symptoms and said that they had picked up from another forum that there was yet another person with the same issue and they had reported a semi-not-really-fix: sticky keys. If I enable the switching on of sticky keys and then hit shift 5 times to bring up the "do you want to turn on sticky keys" dialogue, my sounds come back (regardless of whether I click yes or no).

Why is it only a semi-not-really-fix? Because it only lasts for a few minutes and then the sounds go again. This is exactly what was reported in the thread that I found and, apparently, in the thread that the poster had got their information from.

Soooo, anyone got any ideas? Like I said, it's a weird one and not massively important but I do sort of rely on some of those sounds to grab my attention when I try to exit a program without saving and so on.

User avatar
Rachael
Developer
Developer
Posts: 3614
Joined: Sat May 13, 2006 10:30

Re: Win 7 system sounds weird problem

Post by Rachael » Sun May 15, 2016 9:35

I wish I could help you but I have a similar, albeit different problem in Windows 8.1, that seems to come and go.

Mostly, after using Ventrilo, sounds in Seamonkey (a Firefox-type browser variant) do not work. Sometimes it does, sometimes it doesn't, in the end I have to restart the computer.

What you can try is go to the admin command prompt and type the following commands:

Code: Select all

net stop audiosrv
net start audiosrv
It restarts the Windows system sound service. Do be aware that the service is vital to your system's audio infrastructure - I'll have no idea why Microsoft decided it was suddenly a good idea to route all of the system sounds through a single process, but there it is - your system will register as not having audio drivers installed at all without it. I'd see if tweaking around with it has any effect. If you can find the process ID, you can also elevate its priority to "realtime" to see if it makes any difference.

Playing around with this service has at times fixed random audio issues I've had with every Windows version since Vista - your mileage may vary.
Spoiler: Zen Sarcasm

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4589
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: Win 7 system sounds weird problem

Post by Enjay » Sun May 15, 2016 10:33

Thanks for the suggestion. The commands didn't change anything but I'll look deeper into the process to see if there is anything I can do.

What mystifies me is why the Sticky Keys thing makes a difference. What I have noticed with that is that as soon as the "do you want to start sticky keys" dialogue appears, the sounds come back. i.e. I hit shift 5 times and the dialogue appears, and so do the missing sounds. Even if I do nothing with the dialogue, the sounds will now be working. I did toy with just leaving the dialogue there, or minimising it but after a few minutes, it disappears and so do the sounds. The dialogue disappears after pretty much the timespan that the "fix" worked for if I'd pressed either "yes" or "no" to enable sticky keys and dismiss the dialogue. I assume that something about sticky keys only remain active for a few minutes and once it auto-dismisses itself, whatever allowed the sounds to come back stops happening.

User avatar
Rachael
Developer
Developer
Posts: 3614
Joined: Sat May 13, 2006 10:30

Re: Win 7 system sounds weird problem

Post by Rachael » Sun May 15, 2016 12:57

That is very strange. I wish I had more insightful thoughts to give you.
Spoiler: Zen Sarcasm

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4589
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: Win 7 system sounds weird problem

Post by Enjay » Sun May 15, 2016 18:13

No worries. Thanks for the suggestion anyway. Perhaps this might be the thing that makes me upgrade to Win 10. I've been putting it off because of the auto-updates in Win 10 and, more importantly, because it always takes me forever to set things up how I want them after an OS install.

User avatar
Tiger
Developer
Developer
Posts: 856
Joined: Thu Feb 25, 2010 3:44
Location: United States

Re: Win 7 system sounds weird problem

Post by Tiger » Sun May 15, 2016 19:19

The only things I can come up with are either: Registry corruption or default output sound is mixed up. The only suggestions I can come up with: See if any programs are redirecting sounds incorrectly, recheck the sound properties actually exists:

Code: Select all

regedit: HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\*\[YOUR_PREFERED_SOUND_SCHEME]\
If they exist and everything is fine then check any recent programs, it might be possible that any programs you installed or updated are changing the output sound properties. If this isn't the case, then - might be best to reinstall Windows.

Sorry I don't have any exact answers for this....
Nicholas "Tiger" Gautier

User avatar
Rachael
Developer
Developer
Posts: 3614
Joined: Sat May 13, 2006 10:30

Re: Win 7 system sounds weird problem

Post by Rachael » Sun May 15, 2016 19:35

I don't recommend Windows 10, at least not right now. Some people mold into it just fine, and that's good for them, but I can tell you from personal experience that all the new stuff is a bit jarring to get used to.

If you do go through with the upgrade anyway, I would strongly recommend installing ClassicShell - at least for the Start Menu. Don't get me wrong, Windows 10's start menu is powerful and usable in its own right, but it's too far removed from Windows 7's for my taste, and I use the same program in Windows 8.1 anyway.

Tiger may be right, a reinstall might be in order, but Windows 7 can "self-heal" itself, which I would do first before an actual reinstall. Try "sfc /scannow"
Spoiler: Zen Sarcasm

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4589
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: Win 7 system sounds weird problem

Post by Enjay » Tue May 17, 2016 19:57

Thanks for the input.
Tiger wrote:Suggestions...
The summary of the problem is that any sound scheme that is properly set up will not play certain system sounds unless the "do you want to turn on sticky keys" dialogue has been active in the last few minutes. It's a problem that just appeared one day without a cause that I can think of and I have found a couple of people online who have experienced the exact same symptoms but have not reported a cure.

I've checked all the relevant registry entries relating to sound schemes. Indeed, changing sound scheme to a default one made no difference (nor did creating a new user and logging on with the new account) and the sound schemes start to work properly once the sticky keys dialogue is active (but only for a few minutes). So the basic setup of the sound scheme system is fine, the sounds are in the specified locations and work. It also doesn't seem to be a sound driver issue because I have reinstalled them and also tried a USB headset that doesn't play via the sound card. So it seems to be something about the OS that is stopping certain sounds playing.

I can't think of any software that I installed or which would have changed system settings around the time that the sounds stopped working properly. I guess something must have but I can't think what it was.

A reinstall of Windows might be the thing to do, and my machine is feeling a bit like it could do with a spring-clean anyway. However, it always takes me forever to get things back to the state that I want after an OS reinstall so I've been resisting that. If I do, however, going for Win 10 might make sense seeing as how it is the new/current MS OS and there would be loads of upgrades to my copy of Win7 after a reinstall anyway.

Eruanna wrote:Win 10 insight and sfc...
I am becoming familiar with Win10 because we have one desktop and one laptop in the house that uses it. They are not my machines so I don't use them too often but the OS does seem reasonably approachable for a Win7 user. Much better than Win8 anyway. I'm already familiar with Classic shell and actually use it on my Win7 machine anyway. It provides less of an advantage on Win7 than it does on a Win8 machine but it can still provide some nice features on a Win7 machine.

I guess one thing nudging me towards a Win10 upgrade is that I believe that the offer of the free upgrade expires at the end of July. Not sure what they will do after that though.

I tried the sfc /scannow thing but it didn't fix the problem.

User avatar
Rachael
Developer
Developer
Posts: 3614
Joined: Sat May 13, 2006 10:30

Re: Win 7 system sounds weird problem

Post by Rachael » Wed May 18, 2016 6:02

Well if you're already used to Windows 10, you might as well go for the full upgrade. Make sure you google privacy settings so that you have a chance to set things up the way you want. There are privacy editors out there for Windows 10 that can set all your settings on one screen - which is helpful.
Spoiler: Zen Sarcasm

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4589
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: Win 7 system sounds weird problem

Post by Enjay » Wed May 18, 2016 22:53

I've certainly seen a few comments relating to Win 10, privacy and the default setup. I'll see what is out there to make setting things securely easy.

When you upgrade, what's the process like? I mean, I know that I can update and keep most or my programs intact but how likely is that to carry over crud from Win 7 that is cluttering things up? Presumably a "wipe everything and install a clean copy" option is also available. Presumably that would be much cleaner but would take me much longer to set all my other stuff up.

I'd actually quite like to download the Win 10 update and install at a later date when I'm ready but whenever that thing pops up from the system tray and I click either the upgrade now or the download now and upgrade later option, the app just vanishes after a couple of seconds (again, a problem that I have seen a few people reporting). I can get the update via Windows Update but that automatically goes to the install after downloading without giving me the option of saving the install file and updating when I'm ready.

User avatar
Rachael
Developer
Developer
Posts: 3614
Joined: Sat May 13, 2006 10:30

Re: Win 7 system sounds weird problem

Post by Rachael » Thu May 19, 2016 4:13

A direct upgrade is the only way to keep your "free" license (the one that carries over from 7). You can do a wipe and reinstall, but then Windows 10 will not recognize your former Windows 7 license.

There may be a way to do a clean install and keep your legit license - I have not heard it. If someone knows about that I hope they chime in.

As for what the process is like - well - it's like any other Windows install, really. It will download the files for you and then begin the upgrade. Everything is automated and there's very rarely any problems. It does, however, take an hour or two, if not more.

If you need to download it now and save it for later, use this: https://www.microsoft.com/en-us/softwar ... /windows10
Spoiler: Zen Sarcasm

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4589
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: Win 7 system sounds weird problem

Post by Enjay » Thu May 19, 2016 20:20

Thanks once again. I guess I'll look at doing an upgrade if I get a clear weekend sometime.

User avatar
Rachael
Developer
Developer
Posts: 3614
Joined: Sat May 13, 2006 10:30

Re: Win 7 system sounds weird problem

Post by Rachael » Thu May 19, 2016 21:51

Any time, Enjay. :)
Spoiler: Zen Sarcasm

User avatar
Gez
Developer
Developer
Posts: 1393
Joined: Mon Oct 22, 2007 16:47

Re: Win 7 system sounds weird problem

Post by Gez » Fri May 20, 2016 17:09

Let's hope the upgrade doesn't break anything...

User avatar
Rachael
Developer
Developer
Posts: 3614
Joined: Sat May 13, 2006 10:30

Re: Win 7 system sounds weird problem

Post by Rachael » Fri May 20, 2016 18:32

Agreed, there.
Spoiler: Zen Sarcasm

Locked

Return to “Off-Topic”

Who is online

Users browsing this forum: No registered users and 2 guests