r165 Rendering problems

Bugs that have been resolved.

Moderator: Graf Zahl

Locked
User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4643
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

r165 Rendering problems

Post by Enjay » Mon Sep 01, 2008 15:38

I was playing my son's map

http://www.doomworld.com/idgames/index.php?id=15386

With Dudu's Le-Guns3 loaded

http://rapidshare.com/files/141389332/Le-guns3.rar.html

When I noticed some rendering glitches. First of all, I noticed that the sky was showing through some places where it shouldn't:

Image

And here's how it should look.

Image

Then later on I noticed that the replacement graphics for the teleport flash were showing with a white background.

Image

Although they had been working earlier in the level.

Image

I quit and replayed the level without Dudu's guns and it was fine. Then I went back to Dudu's guns and the glitches returned.

I've also attached 2 save games (I think I zipped the right ones). These are from near where the glitchy screenshots were taken.

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Post by Graf Zahl » Mon Sep 01, 2008 16:25

Le-guns is a grat example of a fundamentally broken WAD.

The teleport fog in it is broken and the missing textures are caused by adding glowing flats definitions so it doesn't work with anything that contains slopes. Apparently its creator never properly tested it.

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4643
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Post by Enjay » Mon Sep 01, 2008 17:05

OK, thanks for the info. I'll link Dudu to this thread so that perhaps he can fix the issues.

Locked

Return to “Closed Bugs”