[1.4.1] Bug: Sprites rendering squished/stretched

Bugs that have been resolved.

Moderator: Graf Zahl

Locked
Zero X. Diamond
Posts: 12
Joined: Fri Jan 08, 2010 0:22

[1.4.1] Bug: Sprites rendering squished/stretched

Post by Zero X. Diamond » Fri Jan 08, 2010 0:55

OS: Windows XP SP2 32-Bit
CPU: 1.67 GHz AMD Athlon XP2000+
RAM: 1 GB
Video Card: ATI Radeon 9200
Driver Version: 8.252.0.0

Description: For some reason, ever since 1.3.9 (I think--this was the latest version before 1.4.0, right?) I have been experiencing rendering bugs in GZDoom with sprites rendering squished either horizontally or vertically. I first noticed this in 1.3.9 where the Cacodemon was doing it every once in a while for a brief moment, but it was nothing too distracting. But as of 1.4.1, everything is screwy: items, weapons, monsters. Custom content seems to be the worst hit with monsters randomly cycling from being floating in the air squashed vertically to back on the ground squashed horizontally. It's something to do with the GL system as when it is deactivated, the problems go away. Specifically it appears to have something to do with the scaling methods: when it is switched to Scale3x or HQ3x, everything that's squished in the other modes looks normal, but then everything else gets horribly stretched out. I'm at wit's end and hope to have some sort of solution soon as I've been using GZDoom for some time now and I much prefer its rendering to vanilla ZDoom... the way everything turns brown in the dark just looks gross to me at this point.

Below are a series of images documenting this bug:
Spoiler:

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4598
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Enjay » Fri Jan 08, 2010 1:38

This thread also seems relevant.

http://forum.zdoom.org/viewtopic.php?f=4&t=24687

User avatar
Rex Claussen
Developer
Developer
Posts: 2427
Joined: Tue Jul 11, 2006 18:36
Contact:

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Rex Claussen » Fri Jan 08, 2010 16:46

Yes, I too noticed this problem yesterday. It appears to have arisen in the new versions of ZDooM/GZDooM.

User avatar
Enjay
There is no dark side in the moon, really...
Developer
Developer
Posts: 4598
Joined: Tue Aug 30, 2005 23:19
Location: Scotland
Contact:

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Enjay » Fri Jan 08, 2010 17:27

What kind of graphics card are you using? So far it has only definitely been identified on ATI cards.

User avatar
Rex Claussen
Developer
Developer
Posts: 2427
Joined: Tue Jul 11, 2006 18:36
Contact:

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Rex Claussen » Fri Jan 08, 2010 19:28

Enjay wrote:What kind of graphics card are you using? So far it has only definitely been identified on ATI cards.
Guilty as charged. I have an ATI Mobility Radeon 9000, v8.20.0.0 (dated 11/10/2005, no update available).

milasudril
Posts: 64
Joined: Fri May 15, 2009 17:21

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by milasudril » Sat Jan 09, 2010 19:39

Zero X. Diamond wrote:OS: Windows XP SP2 32-Bit
CPU: 1.67 GHz AMD Athlon XP2000+
RAM: 1 GB
Video Card: ATI Radeon 9200
Driver Version: 8.252.0.0

Description: For some reason, ever since 1.3.9 (I think--this was the latest version before 1.4.0, right?) I have been experiencing rendering bugs in GZDoom with sprites rendering squished either horizontally or vertically. I first noticed this in 1.3.9 where the Cacodemon was doing it every once in a while for a brief moment, but it was nothing too distracting. But as of 1.4.1, everything is screwy: items, weapons, monsters. Custom content seems to be the worst hit with monsters randomly cycling from being floating in the air squashed vertically to back on the ground squashed horizontally. It's something to do with the GL system as when it is deactivated, the problems go away. Specifically it appears to have something to do with the scaling methods: when it is switched to Scale3x or HQ3x, everything that's squished in the other modes looks normal, but then everything else gets horribly stretched out. I'm at wit's end and hope to have some sort of solution soon as I've been using GZDoom for some time now and I much prefer its rendering to vanilla ZDoom... the way everything turns brown in the dark just looks gross to me at this point.

Below are a series of images documenting this bug:
Spoiler:
Similar things happens on Intel GMA 950 in OpenGL mode. Strange things also happens to high resolution textures (perhaps only non-power-of-2).

dark-slayer-201
Steam - ds201
Posts: 149
Joined: Thu Jul 16, 2009 14:31
Location: South Australia. Adelaide's outdoor mall has 2 big balls of steel!

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by dark-slayer-201 » Sun Jan 10, 2010 3:16

same with Intel Mobile Graphics Accelerator 4500M (Laptop)
on older versions, it only does it to all sprites for a slit second when changing the HQnX\ScalenX
Image
Hello Username

User avatar
Gez
Developer
Developer
Posts: 1394
Joined: Mon Oct 22, 2007 16:47

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Gez » Sun Jan 10, 2010 20:02

Please test if you still get the bug with this build.

Jamesff
Posts: 22
Joined: Fri Oct 05, 2007 22:10

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Jamesff » Sun Jan 10, 2010 21:18

I just began using version 1.4.1, and have the graphics bug (My computer runs WinXP, 2.5 gig RAM, NVIDIA GeForce 5600 video card). I have also tried out the custom build and its fix does not appear to be working for me.

User avatar
Gez
Developer
Developer
Posts: 1394
Joined: Mon Oct 22, 2007 16:47

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Gez » Sun Jan 10, 2010 21:30

Okay, trying something a bit different then. Can you redownload it and retry?

User avatar
Graf Zahl
GZDoom Developer
GZDoom Developer
Posts: 7148
Joined: Wed Jul 20, 2005 9:48
Location: Germany
Contact:

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Graf Zahl » Sat Jan 16, 2010 8:52

fixed

User avatar
Gez
Developer
Developer
Posts: 1394
Joined: Mon Oct 22, 2007 16:47

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Gez » Sat Jan 16, 2010 15:13

Why did you take the gl_trimsprite option from my clumsy and flawed attempts, given that it doesn't do anything?

lzvk25
Posts: 20
Joined: Tue May 15, 2007 1:20

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by lzvk25 » Wed Jan 20, 2010 3:45

I'm afraid this bug is still present in build r721.

CPU : Intel(R) Pentium(R) D CPU 3.20GHz
OS : Windows XP SP2 32-Bit
CPU : Intel(R) Pentium(R) D CPU 3.20GHz
RAM : 2 GB
Video Card : ATI RADEON X850 XT Platinum Edition
Driver Version : 6.14.10.6601

:cry:

User avatar
Marty Kirra
Posts: 364
Joined: Sat Jul 09, 2005 4:25

Re: [1.4.1] Bug: Sprites rendering squished/stretched

Post by Marty Kirra » Wed Jan 20, 2010 22:44

I'm still getting the bug in r721 as well.

Locked

Return to “Closed Bugs”